Sunset and sunrise automation issues in ios

I am not able to create an actionable alert in automation using the sunrise and sunset option.

For example,

I created an automation under shortcuts app to create an alert to send me a text message and call one hour before sunset on a different device- a Samsung running the latest android version ( not the one on which I have created the automation which is an iPhone )

The automation doesn’t execute even though I have selected the option to execute automatically without asking

what is the solution to this problem?

Do I have to change any settings? The alerts do not work neither with iMessage Nor with WhatsApp.

I am using the same automation but with a specified selected time to send messages both by sms and WhatsApp and also to make a call both in one automation

WhatsApp does not have any sort of face ID or password protection to open so it is not restricting sending messages

The automation runs perfectly when I test it with the little arrow at the bottom

I am attaching images of the automation and it running below

Please help

do you have any of the location services>system services items turned off?


Weather app set to always as it gives the sunrise and sunset setting

Shortcuts - set to when in use it also runs as is without change when I run it manually by pressing the arrow button

It is set to run automatically

The automation runs if I change setting to fixed time

Have you tried and ruled out all the suggestions in this topic?

Also it would be worth modifying your post/topic tags to just be shortcuts and iOS. This has nothing to do with Automator, which is a macOS app.

1 Like

I’ve amended the topic

Regarding suggestions
Where will I find those
I have a specific issue and I have tried all available options suggested by Apple and other forums

Specifically in the topic linked to above.“Shortcuts based on sunrise/sunset don’t work” from 2020. There are queries and suggestions in that discussion covering exactly the issue symptoms you describe - though the cause may not be the same as yours, it may be, and maybe one of th suggestions in there might work for you.

That topic is from this forum, not an Apple owned or ‘another’ forum, so perhaps you have not yet tried whatbis suggested there; but “all” is a pretty encompassing suggestion of what you have covered in prior research, so your level of success may well vary.


Thanks I’ll look into this
I’m surprised Apple hasn’t addressed this and yet they give one an option which doesn’t work

I have an update

The shortcuts are working

Spent the entire morning with the Apple support team

They asked me to reset everything which I did and the shortcuts started to work

Thank you everyone for your help

Glad to hear you now have it working. Were there any additional steps to the resets I outlined here for this issue?

I’m just wondering if there are any new additional ones that may be useful to others looking for a solution and where my previously specified steps don’t work.


I am adding images of the automation it works perfectly. There may be a 2/3 minute time difference from what it shows as in your weather app but that is because it factors in your exact location

I had to reset all services on my phone. So that included my location and Wi-Fi This clears up all errors if any

Since I am allowed only one photo, I’m replying in two posts

This is the second one

One hour before sunset I get the above information

I’ll take a picture of the same run just now and share as well

1 Like

1 Like

Are these a reply to my query? If so, my question was about the resolution of the issue with the triggering, not with how the shortcut works. You went through a number of steps to reinitialise the device, and I am wondering what the difference was to the reinitialisation steps given in the link I posted previously. If there are other steps not covered in those steps, then it would be useful to explicitly list them out here for anyone else who comes looking for a solution in the future.

The only difference is that I had to reset my settings completely
Toggling them on and off did not work
Dissembling and reenabling did not work
As soon as I reset Network settings , everything started working -

I had to re-input my Wi-Fi data
My location data needed to be deactivated
Every time I open a new app , it now asks my options on how I need location enabled and I choose - allow when app is use

So just to confirm. When you tried resetting network settings that didn’t work, but a full factory reset (which is the most literal translation of “reset everything”) did work.

The opposite

Reset network settings worked
Factory reset not required

My apologies if I did not convey correctly earlier
I have edited my reply

1 Like