Siri Shortcuts Save File

While I’ve been on my Christmas vacation I’ve been playing around a little more with Siri Shortcuts. I have one in particular that has been working flawless for years (all the way back to the Workflow days!). I was making some changes to a workflow for Toggl on my 12.9 2018 iPad Pro running iOS 12.1.1.

When I went to test this new workflow on my iPhone 8 running iOS 12.1.2 Shortcuts kept crashing. No big deal I thought. I’ll just uninstall and reinstall Shortcuts and that should fix that. And it did. The crashing behavior went away.

The problem is that since I reinstalled Shortcuts the ‘Save File’ action no longer lets my select a ‘Service’.

This feature IS available on my iPad but not on my iPhone.

I’ve tried uninstalling Shortcuts, and Dropbox. I’ve tried removing and adding back Dropbox to the Files app.

If I instead say 'Ask where to save file ’ I CAN browse to Dropbox but that’s not what I want.

Any ideas on what needs to be done to fix this?

This was being discussed a short while back. Unfortunately so far there’s nothing that’s resolved it for everyone.