Dropbox missing in Shortcuts after restoring iPhone from backup


#1

I have a shortcut that appends to a text file in Dropbox, using the Append to File action. It runs normally on my iPad, but on my iPhone the action’s “Service” option is missing, which causes the shortcut to default to iCloud Drive and fail with an error message saying “the file doesn’t exist.”

It ran fine until I had my iPhone’s battery replaced yesterday and, as part of the process, had to erase the phone and restore it from an iCloud backup. Something must have gotten lost in the process and now I can’t find any way to get Dropbox to show up again as an option.

I’ve tried:

  • uninstalling Shortcuts, rebooting and reinstalling;
  • uninstalling Dropbox, rebooting and reinstalling;
  • removing “Siri Shortcuts” from “Connected apps” on dropbox.com and re-authorizing from Shortcuts on the iPad.

Does anyone have a clue on how to fix this issue?


Siri Shortcuts Save File
Shortcut to read and format multiple IFTTT notifications containing URLs
#2

Everything you have done sounds eminently sensible. Could you perhaps post a screenshot of what you see, or rather don’t see? I’m curious as to whether the action has no option at all, or if it is greyed out, or something else.

I do wonder if it is a corruption in the shortcut rather than an integration issue. I realise it is sync’d with your iPad which has no issues, but starnger things have happened and it could be a one sided issue. Presumably you are also seeing this for newly created shortcuts, and not just for this one existing shortcut. Correct? Also, have you tried removing and readding the action in the Shortcut? Maybe it is worth sharing the shortcut to ensure others can run it.

For what it’s worth, I disconnected Dropbox myself to see if I could reproduce the issue. I couldnt as it happened. I added a Get File action to a new shortcut, tapped on the service parameter (which is what I’m taking it to be that you don’t see when you create a new shortcut), selected Dropbox, selected allow access, allowed access via the Dropbox app, and then saw the Dropbox features enabled in Shortcuts.

Note, the toggle to the left of the remove cross (top right on the action) then provides me with an option to sign out of Dropbox.


#3

This is what “Get File” and “Append to File” look like for me in a new, empty shortcut:

The “Service” row is completely missing, as are the toggles in the top right corners. The “Allow Access” button, as seen in your 3rd screenshot, has not shown up at all since the restore.

I don’t think it’s a corruption issue; it looks like a bug in the app. It should be asking for my permission to access Dropbox but is failing to do so for some reason.


#4

So whatever Shortcuts uses as it’s trigger to display that isn’t being captured for you. The fact that it can apparently not be displayed at all suggests it is something local to the device and the obvious reference point would be something related to the Dropbox app.

I’m taking wild guesses now as I don’t know what the trigger is exactly, but have you tried uninstalling both apps (rather than just one at a time), rebooting, and then reinstalling both?


#5

I’ve just finished trying that; the problem persists.


#6

Just started listening to the podcast thins week. Had this issue and brought me here. What devices are you guys using. My ipad cant select any services iCloud or drop box, but my iPhone doesn’t have any issues.

Wondering if anyone have more information?


#7

Anyone have any luck on this??


#8

@Diogo were you able to resolve? Out of the blue, today, my iPhone Shortcuts began exhibiting the exact same condition. iPad is working fine. — jay


#9

Still no resolution.

A few days after my post here, the app started to consistently crash a few seconds after launch. Reinstalling it stopped the crashes, but the Dropbox issue remains. The iPad is still fine.


#10

Thanks for the response. I have 3 iOS devices… 2 iPads and iPhone. One iPad works fine. iPhone Shortcuts app works, in general, but exhibits the Dropbox issue. Second iPad exhibits problem you describe… immediate crash after start. I haven’t re-installed on that iPad.

Frustrating problems. But I trust we will see resolution…


#11

I “fixed” my problem… Just finished converting my Shortcuts to use iCloud instead of Dropbox. :roll_eyes:


#12

I’ve got the same problem my iPad shows Dropbox but my phone doesn’t?


#13

Has anyone tried signing out of iCloud and then signing back in on the effected device? I restored a backup to a secondary phone and the problem was there. I logged out of iCloud on the secondary iPhone and the problem was fixed. I’m hesitant to do this on my primary phone ( not really sure why … perhaps I don’t want to have something else get messed up ).


#14

@BrainyLiving, have you tried @Milo’s suggestion yet? I don’t have the issue and his suggestion seems to have gone unchecked so far.


#15

No, I haven’t. In fact, this was the catalyst for me to move mostly off of Dropbox.

I updated each of my Shortcuts that used Dropbox to point to iCloud instead. Coincidentally, my annual Dropbox re-subscription came up in January so I used that as rationale to make the total shift. Back to the free tier and largely using iCloud now.


#16

I finally had the time to logout of iCloud to see if that fixed the problem. It did, and my iPhone seems to be mostly back to normal. That being said, there’s a ton of stuff that I had setup with iCloud that I didn’t realize and I keep coming accross things that don’t work the way I expect them. For a couple of days none of my music was on my phone and it took a message from the Music app to tell me what was going on.

Just a word of warning. It seems like this worked for me, but as always, YMMV.


#17

I checked my shortcuts today after updating to iOS 12.1.3 and things seem to be back to normal.

Dropbox showed up again as an option in “Append to File” and gave me an “invalid token” error message at first, but worked as expected after signing out and re-allowing access.

I hadn’t checked in a few weeks, so I’m not sure if the update is responsible for the fix, but if anyone is still having this issue, try updating to the latest iOS.