Siri Shortcut worked, now it doesn’t - download/rename mp3

I have a Siri Shortcut that stopped working correctly. It downloads an mp3 from url, renames it & saves to a nested folder on Dropbox. It now doesn’t accept the “ask when run” file name input & saves one level above where it should. Any suggestions? I’ve not shared a Siri Shortcut before but I believe I have figured it out. The shortcut can be viewed here -

Thanks in advance,


You don’t note when it stopped working, but there is a bug in Dropbox in Shortcuts. Was it that it used to work in Workflow by any chance?

However, the new beta version that dropped last night for me seems to have fixed the nested folder save issue, based on a single quick test I did just now.

1 Like

New beta of shortcuts? Hmmm, why don’t I see that?

It’s a new beta not the same as the old one (I have Shortcuts twice in TestFlight now), and on the developer portal I would need to register again to get it.

Aha! I shall go and register again!,

Hey sylumer,

It stopped working right around the time iOS 12 came out…so yes, it worked in Workflow just fine. I believe it worked for a day or two in Siri Shortcuts but I don’t recall when it actually stopped working. The current functionality I described early is a tolerable nuisance if the current beta will restore proper working order once it is publicly released.

I believe you indicated the latest beta fixed this issue. Do you think I should just wait for this update or adjust the shortcut?

If you need to use it often enough that it’s a frequent friction, but you can fix it, I’d duplicate the existing one, fix it, and then use it until the next public release; at which point you could presumably revert to your original one and remove the duplicate.

Thanks sylumer, I think I can correct a duplicate version for now. If I have any issues I may ping you through this forum again but will try to figure it out myself first.

I appreciate your willingness to help.


1 Like


I was talking about the public release of iOS12 - I never installed the betas or signed up for the Shortcuts beta. I found the issue in a Workflow workflow that I’d built and was using regularly before iOS12 and Shortcuts was released.

Good to hear it looks like it’s resolved in the next Shortcuts release though!

Just to clarify…

When updating to iOS 12, Workflow is replaced by Shortcuts. In the initial public release of Shortcuts, there appears to have been an issue with the Dropbox integration. Prior to this, The Workflow app had no such issue.

A new beta version of the Shortcuts app was release recently and the Dropbox integration appears to be much improved, resolving most, of not all of the Dropbox related issues. The next public release of the Shortcuts app will be based on this beta and so it looks likely that a resolution is due imminently.

1 Like