No widget updates

I seem to be the only one having this issue, Scriptable widgets on IOS 15 do not update on multiple devices, everything was fine on IOS 14

I’ve tried deleting the App and reinstalling, changing the script in the widget, rebooting but nothing has worked

Is this still an issue atm free the latest app updates?

None of the recent updates have helped me. It only affects Scriptable widgets, all other Apps with widgets work and update with no issues

I was meaning about the Scriptable app updates that Simon just released recently. It seems to have helped many others on iOS 15

The Scriptable App updates haven’t helped

Understood. I wonder what’s going on in your case. Seems quite strange

Does the widget get displayed in the app if you call widget.presentMedium()?

If yes, then you’re most likely having memory issues. If you load a lot of data in the widget, then try to reduce that.

Otherwise, if it doesn’t get displayed in the app then you probably have an error printed in the console.

1 Like

Got one update today on all my Scriptable widgets but when I went back into them an hour or so later they were blank again

Part of me wonders if you have a corrupted section of iOS causing this issue, but that would be weird for it to only impact Scriptable widgets

And you said it doesn’t matter what widget you to to load, right? Even if you disable all the other scriptable widgets, then have a very basic one added to Home Screen?

No it affects all Scriptable widgets, today at 05.45 all my Scriptable widgets updated correctly, this is only the second update in two weeks.

However when I went back into them 2 hrs later they were showing the ‘blank’ widget as in my original comment

What’s strange, is on 14.8 with the latest app updates, the colors don’t show on the loading page of the widget like you shown in that screenshot, unless it is small size.

I’ve tried another phone running IOS 15 set up as a new phone so not restored from a back up or data transferred from another phone. I downloaded Scriptable and added one widget, this has also failed to up date in more than 12 hrs

Just curious, what widget is this? does it affect just one Scriptable widget or any Scriptable widget? I tend to agree with @schl3ck that it could be a memory issue on the specific widget. Unless of course it happens to all your Sriptable widgets.

You can try creating a simple widget that just displays short text.

1 Like

I’ve been experiencing the same issue, the widget that won’t load is pretty resource-intensive (any tips for memory improvements for the widget?).

I have another, much simpler widget that is working fine.

It depends on the widget code tbh. I found that using a lot of stacks can be very memory intensive

1 Like

All Scriptable widgets are affected, the same ones worked fine on IOS 14. So far on IOS 15 the Scriptable widgets have only updated twice in 14 days

This is the Sunrise script https://pastebin.com/raw/wEebQNCn

Yeah I’m also reasonably sure this is just a new OS bug, as I never had any issues rendering the widget before the upgrade to 15.

Does the “Refresh all widgets” action in Shortcuts have any effect?

My widgets have been fine, but I’m still on 15.0 - are you on 15.0.1?

No refresh widgets doesn’t work. I’m on 15.0.1 but had the same issues on 15.0