No widget updates

Widgets have just updated, only the third time in over 3 weeks. Any idea why this is happening?

That’s still very odd. I don’t see this problem on my work device that has scriptable widgets and is on iOS 15.0.2

Seems you’ve taken the right steps to delete the app and reinstall, but I wonder about some setting inside iOS itself being corrupted and not allowing the widgets to refresh as often as they should. Have you tried a backup, then restore and setup as new to see if the widgets work then? If they do, you could restore from the backup and try again and see if the issue persists

Looks like I am having also issues with refreshing the widgets.
To me it feels like I have the most trouble with the extraLarge widgets.

On an iPad Pro 12,9“ 5th Generation with iPad OS 15.0.1 and Scriptable 1.6.11 the widget doesn‘t even shows, when I set it up. I have to set up the same Script in a smaller widget and the it will show both.

On my iPad Pro 9,7“ with iPad OS 15.0.2 (19A404) and Scriptable 1.6.11 the Script will be shown right away, but also also will not update frequently.

On my iPhone 12 with iOS 15.0.2 (19A404) i don`t have any issues at all. But I don‘t have extraLarge widgets there.

I’ve tried setting up as a new phone ( on another phone), and installed Scriptable and one Scriptable widget, still no joy

yuck! Yet another reason I’m glad to not be on iOS 15 yet I guess. My work phone is on 15.0.1 and seems to be updating my Weather Overview widget regularly without issue.

Can you share your code? It seems like there might be an issue in it that was not apparent on iOS 14. As you can see, we’re all stumped and don’t know where to look next. Maybe there’s something in the code that might give a hint.

Before you share the code, you might want to strip out any personal information including any API keys :wink:

1 Like

You might be right in my case with your assumption of memory issues. One of the scripts I am having problems with (and had when i posted earlier) is this: This Scriptable iOS Script displays the price of the selected Cryptocurrencies in a widget on your iPhone or iPad. · GitHub. It is working without problems from the app, but not working as good as a widget. It works better, if I do not use a background image, wich could be an indicator of memory issues to me. Also it behaves different on different devices. The most problems do I have with extraLarge widgets on the iPad. The extraLarge widget displays more data so it could be another indicator to a memory issue.
Just now i discoverd the same problem with different code in an early state of developing a new widget. Again my iPhone works better than my iPads where the 9,7" at least shows the data at setup, but the 12,9" does not even show any data on setup. If I put an error (like an object is null) into the code the widget will display the error. Again this indicates a memory issue to me. Here is the script I am working on at the moment: This script is under developement and not for public use. Do not use unless you know what you are doing. · GitHub

I found the problem I had. It was, as @schl3ck early suggested, a memory issue in my case. One of the csv files I need to load has quite a few lines ( Since I only need the first 120 lines I added a “slice” to my request and now the widget shows on the homescreen and refreshes like it is supposed to.

let rawData = (await new Request(csvFile).loadString()).slice(0,6000)

I had some ups and dows during the redesign of the script and I think it is really annoying, that OS/Scriptable does not give any hint to the user, that the memory limit ist exceeded.


This is very interesting that doing this slice is working!

I thought that the data alone is too much and the widget crashes but thanks to you we now know that it probably crashes when you try to save it to a variable… Or something else. It probably depends on the implementation of the Javascript Core library in iOS. But thanks for sharing this!