Apple Watch workout trigger not working

I have a personal automation shortcut set to turn off the lights in the room where I workout when I end the workout on my Apple Watch. It was working perfectly, and then it wasn’t, for no apparent reason. I’ve tried setting it any workout, rather than a specific type, and I’ve tried start, end, and either start or end. Nothing works. I also tried other, non-homekit actions, including triggering a notification in PushCut. Nothing! But manually triggering the actions within the Shortcuts app works as expected. Which leads me to conclude that somehow the workout trigger itself isn’t being registered.

Has anyone seen anything similar or have any suggestions? Thanks.

When did you last restart your devices - watch, phone, home hub/tv (whatever they are talking to), and if you re using something like a Hue hub, that too?

First thing to try when things were previously working is always a reboot of everything.

I tried that. No change. I can’t get the workout trigger to do anything at all, even just play music. I’ve tried using the “ask before running” setting and I don’t get anything from that either. Somehow the watch is not communicating that a workout has started or ended. Workouts do show up in the Activity app, though, and the watch behaves normally as far as other functions involving pairing go.

I think I’m going to have to try unpairing and re-pairing as my next step.

I have had the cat same issues. Suddenly, shoutout reason my start nay workout trigger has stopped working. I posted on Reddit about this issue and got a new replies with other people saying the same. I was hopefully that updating to 14.7.1 would fix this but it has not.