Works on iPad but Broken on iPhone

I’ve got a fairly simple shortcut asks for a few bits of user input and then saves that input to a Numbers file stored in iCloud. It works great on my iPad but doesn’t work on my iPhone at all.

When I tap on the icon in Shortcuts on my iPhone to run it, it shows the progress indicator icon at the top right but then nothing happens and the Shortcuts app effectively crashes. Only a force quit will escape the shortcut running. If I try instead to tap on the ellipsis icon “…” to edit the shortcut, the same behavior results.

I’ve tried a number of workarounds: duplicating the shortcut and then trying to run that one on my iPhone; making a duplicate of the original and running that on my iPhone; saving the shortcut to iCloud and then clicking on the iCloud link to acquire I on my iPhone; sharing directly via AirDrop from iPad to iPhone; editing the original and/or the dupe in hopes that saving the shortcut again will somehow fix any corruption. None of these worked; they all produced the same behavior on iPhone.

Luckily the shortcut is easy enough to recreate from scratch. But I’m wondering if there’s a more reliable way to salvage a shortcut when it gets into this corrupted state? Thank you.

1 Like

Can you please share the shortcut?

Oh yes sorry should’ve done that originally.

Here you go.

Have you tried not including the file extension in the get file action?

Works fine on my iPad and iPhone after creating the Numbers file. And I don’t see anything suspicious inside the shortcut. Must be something other than the shortcut itself, like Numbers, iCloud sync, etc.

Thanks. I think it would make sense to me that it was something other than the shortcut itself if I were able to edit the shortcut on iPhone. But when I tap on the ellipsis icon, the whole Shortcuts app freezes and necessitates force quit. That would suggest it’s either the shortcut or the app database or something?

Just tried that by making the edit on my iPad, but on my iPhone I still couldn’t even edit the shortcut, much less run it. So odd. Thanks for the idea though.

Okay I think I’ve figured this out, or identified the bug. The Get File from Folder action was pointing to the file in my iCloud Drive/Numbers/ folder. For some reason it’s very, very slow for the iPhone to access anything in the folder, even though there are only about two dozen files in there, all less than 1MB.

Anyway, as soon as I moved the file to a different iCloud Drive directory, the shortcut started running instantaneously. As a side note this seems to indicate that even when opening a shortcut to edit it, the Get File from Folder action is run in some way.