Wind down trigger not working?

Hi all,

I tried to set up an automation triggered by “When wind down starts” but it never runs.

My “When waking up” automation runs each morning and every evening I get the iOS notification “Wind down is starting soon”. So I feel I have at least some parts in place.

Any idea what I’m missing?
I could just run a time based trigger every evening, but I want it to work like it’s supposed to.

Nils

@Nils – would you share the automation with us? It is very hard to tell what might be missing or fixable without knowing what you’ve got :slight_smile:

I’ll also say thanks – I haven’t had a lot of time to play with the new iOS features ye – I didn’t realize wind down could be a trigger! Now I’ve got to go play with Shortcuts instead of getting work done…

Sure! It’s a very simple shortcut, that sets my watch face (“Zifferblatt” in German). And because I was trying to debug it, there is also a notification in there.


@Nils – thanks for sharing the screenshots. I was able to replicate your automation as set up on my phone/watch. From the perspective of figuring out your problem, I’m sorry to say that it worked fine for me. The one thought I have that you might try – I see that you’ve set up the change watch face as a completely separate shortcut and then are executing the “run shortcut” action. You can put the “set active watch face” action in the automation itself – instead of When Wind Down Starts --> Action = Run Shortcut, try When Wind Down Starts --> Action = Set Watch Face.

Full disclosure – this falls into the “something I saw that you might try” category of solutions, not the “I have an understanding of when and why Shortcuts don’t work and this makes sense” category :slight_smile:

My one other question for you based on having played around with the Sleep/Wind Down settings last night when trying to figure out the issue with your shortcut – are the other parts of Wind Down behaving the way they should? I got a “wind down is about to start” notification 1-2 minutes BEFORE wind down time (e.g., if my “bed time” is set at 10:30pm (2230) and my wind down time is 15 minutes, I get the notification around 10:13pm (2213) for wind down to start (and the automation to run) at 10:15pm (2215). If that isn’t happening on your watch, another possibility is that there is something in the way you have Sleep setup that is keeping wind down from triggering the automation.

Thank you for testing!
I get the “wind down is about to start” notification. I will try to see, if other things are also happening. At least I have now somewhere to start.

Hmmm, maybe I need to activate the automatic sleep mode. At least then it is working. I thought (hoped!) that wind down and automatic sleep mode are independent.
Thanks for your help!

1 Like