Why will Shortcut to create new Draft not work on Apple Watch?

I have a simple Shortcut that I’m trying to implement to enable quick voice dictation of a draft on my AW. When invoking this shortcut via Siri on either my iPhone or iPad it works fine. The draft is created as expected. When I invoke the shortcut on my Apple Watch (ultra, fwiw), the dictation is captured, but a blank draft is created. Am I overlooking a step?

I had the same result. I think it is the dictation step based on my tests.

This workaround should help.


1 Like

Thanks for the quick response. I had tried a similar workaround with an intermediate Text action, but that didn’t work either. The Variable action resolves the problem.

I tried Text actions, speak actions, adding to variables, and a couple of others to see how the behaviour changed. Same result as you with the Text action, but the add to variable seemed to work pretty reliably in my testing.

I think you have fixed it now, but for interest, you can just add a drafts complication.

The thing with the Drafts complication is you can’t immediately trigger to dictate. It has been that way since the watchOS 8.1 beta in 2021. The workaround since then was to dictate in Shortcuts and pass that dictation into Drafts.

If you would like the feature to go back to how it used to work, there is a feedback item with Apple - FB9685074. But, Apple apparently did it intentionally, and seem curiously loathe to walking it back or even providing a setting for it.

I have a drafts complication on my Apple Watch.
I touch that and then the microphone and dictate until finish and then touch “Done”.
A new drafts entry is immediately created.

That is the extra step now required that using a shortcut can remove. By switching the Drafts complication for a Shortcuts complication, you can remove the need for the microphone selection.

1 Like