WhatsApp message via automation error

I have a persistent issue when I try to set up automation to send messages via WhatsApp

I keep on getting this message that states the number is not registered with iMessage

I created an automation to send birthday greeting which works perfectly well with texts , it scans my directory and whoever’s birthday it is it send a message

This is my automation

Then I replicated to send message via WhatsApp

Now when I try the WhatsApp automation this is the error I get

I’m unable to use WhatsApp at all in any of my automations due to this error

Please help

That message seems to refer to iMessage which is Apple’s messaging system, so that looks odd.

Try building out your shortcut again, but start with selecting a contact and messaging them from WhatsApp to confirm that action works for that contact. Then duplicate and modify the Shortcut around that to build it back up to what you want, checking for issues at each stage.

Also remember that screenshots only show some of what makes up a shortcut. Share a link to the Shortcut so people can look at settings, magic variables, etc. We can’t tell exactly what you have built otherwise. It becomes much more about guesswork rather than analysis if all we get are pictures rather than the ‘code’.

1 Like

Sure here are the links

This is the WhatsApp link


This is the iMessage link where the message was either as iMessage or SMS


This problem has cropped up quite recently and also when I try to send a message through WhatsApp say for example, I want to send a picture then sometimes it says open WhatsApp to send it

I thought that it might be a problem with WHATSAPP, so I have reinstall it, but I’m still facing the same problem . There seems to be some somewhere.

So have you tried the simplest test I suggested?

1 Like

I did it didn’t work

Same issue

Something is wrong with my automation and WhatsApp integration

I haven’t got any authentication on WhatsApp to restrict it

If you start with the simplest possible shortcut does that continue to fail in the same way?

Using someone you have messaged in the WhatsApp app so you know they are enabled for WhatsApp.

1 Like

It failed. - same issue

And that is your underlying issue.It is purely within the send message action.

What happens if you simpkify this even further and explicitly type in their telephone number instead of specifying a contact from which the action must derive the number?

Please do not post anyone’s telephone number in any response. Just success/failure and the text of any error should suffice.

1 Like

I changed To purely a number and again the same error I just don’t understand what is going on

Should I just reset the settings ?
Maybe that will fix this

Last time when I had a sunrise and sunset issue if you recall I reset the settings and it came back to normal. It is a lot of work but I’m sure it’ll resolve a lot of issues if it works out.

I did a reset network settings - no change
I’ve initiated reset all settings - it says wait an hour

Will keep u posted

Network settings could affect how your phone geolocates, which would be used in solar calculations. I don’t see how it would affect how a donated Shortcuts action from the WhatsApp app would function/fail.

You should confirm that WhatsApp is up to date. If not, update it and review.

If it is up to date, you could remove and reinstall WhatsApp and see if that affects the action.

As I have noted previously, I choose not to use Meta’s apps, but maybe someone who does could confirm if they can reproduce it on their OS and app versions, or if it works for them.

I deleted the app
Then Reinstalled it
I also reset the network
Still the same issue
It has something to do with iMessage. I suspect because why is my message being routed through iMessage through WhatsApp there is an identity issue. Even though I am saying send a message via WhatsApp. It is still sending the message via iMessage or trying to send it through iMessage. That is why it says it’s not recognised as an iMessage number, maybe I’m wrong

I tried asking the WHATSAPP guys and they said my system is working alright. Not very helpful though I guess.

You have already ruled this out, because earlier you types in the direct number of the recipient.


Same sort of explanation with this one unless you have been messaging yourself - which would not have been a valid test.


Another reference to this error in this topic. But that seems to pertain to a registration issue and again you have been using a number for testing that you know to be working in the app, which rules that out. But it does note my own thoughts that the implementation is a bit off in terms of pushing an error referencing iMessage. I don’t think it is actually trying to send via iMessage - everyone would be up in arms from both companies and end users as messages would potentially be turning up in the wrong places. That’s a level of data issue where the tech media would probably pick it up.


On the basis that you have diligently and accurately tried everything, I think as I suggested above, that you need other WhatsApp using forum members to corroborate if this is a widespread issue or not. I.e. can other replicate the same behavior on their devices.

1 Like

Hello guys I finally found the solution for this
1st to the setting turn of iMessage then go the shortcuts and delete everything and recreate it also contact should be unique name so it will send to the right person if didnt work msg me

1 Like

Hmm I’ll give it a try
But there is one thing since we are on the subject
Whenever I receive an attachment or I have a file which I want to send via WhatsApp
I select the option of sending it to WHATSAPP
When I send it, it says open WhatsApp, and there I have the document with the red! Exclamation mark
So I have to physically go to WhatsApp and send it
That is another issue Would that be a cause for this problem? I will try the iMessage thing in the morning

It worked ! Thank you :pray:t3::pray:t3:

1 Like

I turned off iMessage then when I tried to send WhatsApp it was picking up 3 locations so I deleted two and now it’s fine so far ! :crossed_fingers:t3:

Can you explain what you mean by “it was picking up 3 locations”? I’m afraid I don’t understand what locations you are referring to.

1 Like

Good at least we found it

1 Like

The first option I selected was to send the text to the contact

I have created multiple contacts linked to that particular contact just for my reference

So when I run the automation, it was picking up all those contacts because that individual’s name was also there

I tried all other options and then eventually I instead put the option of phone number

And it worked, I am going to enclose the Shortcut for your reference and a screenshot of the same

By the way, I saw your YouTube channel . Very interesting

How I made out it was yours was because it had the same logo so I hope I’m not wrong