Warning: iPhone 13 & iOS 15 Shortcut Issues

I set up my iPhone 13 Pro Max using an iCloud backup yesterday.

  • I have 435 Shortcuts that were organized into 31 folders
  • iPhone 12 Pro Max & iPad Pro had iCloud Sync enabled for Shortcuts
  • I did not use the iPhone 12 or the iPad Pro during the iPhone 13 set up / restore from iCloud process

When the iPhone 13 was set up enough to start using, I opened the Shortcuts app and my Shortcuts were in the folders I put them in.

When I paired my Watch S6 with the iPhone 13 and started testing it, I noticed some Shortcuts on the Watch that should not have been there.

When I opened the Shortcuts app on the iPhone 13, the Shortcuts were NOT in their folders. They were all in the All Shortcuts folder :woozy_face: UGH!!!

Since the iPhone 12 and iPad Pro had iCloud Sync enabled, the Shortcuts were not in the correct folders on those devices… :woman_facepalming:t3:

Per my conversation with an Apple Sr Advisor today, there is no way to recover the folder organization. :cry:
And I don’t have screen shots so will have to rely on my memory… :woozy_face:

Next time I do any major updates / changes, I will disable iCloud Sync on at least one device.

iOS 15 Update Errors

After updating to iOS 15 and iPadOS 15 on Monday, many Shortcuts had errors / crashed.

I tested ~ 80 of my most used Shortcuts. In addition to having to grant permissions many, many, many times…

  • 25 had errors / crashed

** Couldn’t Run “If Or”: The action couldn’t run because the runner quit unexpectedly
***[Toolbox Pro Action - fixed by changing to native iOS If action]

** Invalid shortcut file
***[didn’t like a Shortcut name containing /]

** Couldn’t Run “Edit Bookmarked File”: The action couldn’t run because the runner quit unexpectedly.
***[Toolbox Pro Action - fixed 1 instance by switching to native iOS Append File action & creating a new log file to be appended - but it broke again on iPhone 13 - see below]

** The operation couldn’t be completed. (kCLErrorDomain error 2.)
***[Tesla Remote app actions or my shortcut that looks up locations in my Contacts - open issue]

Right before my iPhone 13 was delivered, I fixed my Append Network Log shortcut and tested it repeatedly on my iPhone 12 and iPad Pro and it worked on its own and as part of other shortcuts that call it using the Run [Shortcut] action …

Fast forward to my iPhone 13 with its unorganized Shortcuts…

  • Append Network Log shortcut did not work on iPhone 13, but did work on iPhone 12 & iPad Pro :woozy_face:

** Couldn’t Run “Append to Text File”: The action couldn’t run because the runner quit unexpectedly.

*** Privacy sheet on iPhone 13 did not match Privacy sheet on iPad Pro so I Reset Privacy on iPhone 13 and this error went away…

** The operation couldn’t be completed (NSFileProvider-ErrorDomain error -1005.)
*** Only action left in the shortcut is Run Transfer of Data Sound [a Star Trek sound effect]

Running Transfer of Data Sound shortcut gave this error:

  • The file doesn’t exist.
    ** The file DOES exist - the iPad Pro & iPhone 12 can play it
    ** Privacy sheet on iPhone 13 was blank and iPad Pro had permission to access Shortcuts folder on iCloud Drive
    *** Get file from Shortcuts at path Text was the problem. I replaced Shortcuts with Shortcuts (basically reselected it) and the Privacy sheet updated
    *** The Get file from action has changed in iOS 15. It looks like the action can access any folder not just the Shortcuts folder

Some thoughts on this experience…

  • Error notifications have more information, but the Apple Sr Advisor I spoke to couldn’t find anything on the error messages. I added a bunch of Show Result actions to narrow down the problematic actions.

  • The Privacy / permission process is a major PAIN!!!
    ** Several of the errors seemed to be related to how Apple implemented Privacy controls in Shortcuts

** Changes to native Shortcuts actions might be fixed by reselecting / replacing the variable or object of the action

As mentioned in another thread, I discovered after updating to iOS 15 that I could not use / restore a shortcut from the backup archives I’ve been creating :woozy_face: :woman_facepalming:t3:

So after learning that, before attempting to troubleshoot, I duplicate the shortcut I am going to fix & append Orig to the shortcut name before I start fixing the shortcut.

  • It gives me a reference to look at as I work
  • It’s also my just-in-case fallback for when I need to start over again :joy: :wink:

Hopefully others can benefit from my experience and NOT have the same errors happen or have an easier time troubleshooting / fixing Shortcuts.


1 Like

Thank you for documenting all this. You would hope 15.1 - now in beta - would make progress on some of these.

The “Action could not be run because the runner quitted unexpectedly” is still not fixed? I get that a lot on iOS 14.6 :disappointed: