Universal Link has stopped working

I use the universal link scheme as a OAuth redirect for one of my widgets rather than the scriptable:/// schema as Google requires https on it’s redirects but when using this UrlScheme:

https://open.scriptable.app/run/Example

I now get a Gitlab 404 error?

Is anyone able to reproduce this issue?

@simonbs can you help here at all please?

It seems to work fine on my devices. However, sometimes iOS caches universal links in a bad state. Can you try to restart your device and see if that fixes the issue?

I’ve tried to restart and have tried removing the scriptable data from Settings > Safari > Advanced > Website Data with no luck

For what it’s worth:

  • If I select the link inside the Discourse app on my phone or iPad, it triggers Scriptable.
  • If I enter it into Safari on those devices it gives me a GitLab 404 page.
  • If I open the URL via Shortcuts on those devices, it triggers Scriptable.
  • If I open it from a link on the page in Drafts, it gives me the 404 page when opening internally, but if I choose to open the link in Safari rather than Drafts’ own internal web view, then it triggers Scriptable.

My devices have been rebooted, but my point is that the result varies a little based on where and how I am triggering the URL.

Maybe that somehow plays into the issue?

So on that note, I get the 404 error after being redirected after a Google OAuth flow, or in other words, in safari.