Trouble with Stream Deck 5.1 and Keyboard Maestro Macros

I just updated the Stream Deck software to 5.1, and now none of my Keyboard Maestro URL macros will run through the Stream Deck. When I push a button on the Stream Deck, a yellow warning sign pops up. I’m using the Website action in Stream Deck with kmtrigger://macro=blah-blah-blah in the URL field. Anyone else seeing this?

If I use KM Link instead, the macro will fire. I don’t really want to rebuild all my buttons, though.

You might be better off asking this in the Keyboard Maestro forums, but I suspect you might have checked the “open in background” option on your buttons which likely breaks things.

I had this issue about 12 months ago with a different version of stream deck software.

Peter Lewis was brilliant and patiently went through the keyboard maestro logging report to try and establish why it wasn’t working. In the end it became clear that the port request generated by stream deck was been rejected/ignored by the Mac operating system, which at that point was Catalina. We never managed to solve it but the problem went away when I did a clean install of Big Sur.

In the meantime I went to using URL triggers for all keyboard maestro macros and I found these to be rocksolid reliable.

Thanks for the response. That option wasn’t checked. The only thing that changed was upgrading from 5.0 to 5.1. Downgrading to 5.0 has resolved my issue.

Thanks for your response. I ended up downgrading to 5.0, which has resolved my issue.

FYI - There is a thread about an issue in 5.1 forcing background opening over on Reddit. I suspect this is what you have encountered.

For what it’s worth, the issue still seems to be present on 5.1.2. Tried it this morning. I downgraded back to 5.0 again, and all is well.