Toggl & StreamDeck - bizarre behavior

Got a StreamDeck XL and trying to get it set up with Toggl. Went into StreamDeck’s app and created four buttons for my four major projects, added API keys, labeled them appropriately, etc.

So I press button #1. Timer starts on my Mac. So far, so good. I press button #1 again, and it saves the info BUT just immediately starts another timer for the same button’s project.

All four buttons seem to exhibit the same behavior. I’d really, really like to figure out what’s going on here. I could go after this with Keyboard Maestro if necessary, but it feels like the built-in stuff should be working better than this.

Anybody have any ideas?

Is it this plugin?

GitHub - tobimori/streamdeck-toggl: ⏱️ Make time tracking a 🍰 piece of cake, with Toggl Track and Elgato Stream Deck (Toggl Track integration for Stream Deck) issues

If so, it only seems to talk about triggering starting timers, not stopping them.

If that’s the only issue I suppose I could make a KM macro to handle the “stopping” part.

That said:

If you start or stop your timer using the Toggl app (web, desktop, mobile) Toggl for Stream Deck will follow by changing the status.

That doesn’t work either.

And when it’s activated, it’s supposed to be a grey button that goes red, stays red, and starts counting up the time. In this case the light only flashes momentarily to red, and the time isn’t displayed.

So something is definitely weird.

ETA: Completely clean reboot, still have the problem.

Posting back with my own solution. It works exactly as documented in the dev’s instructions if I also specify a project, but not otherwise. This is noted as “optional” in the instructions for the plugin, but it’s definitely not optional in practice - at least in my case.

I tried this approach, too. It never really worked well for me.

I ended up using the Timery app (originally on iOS, recently added a Mac app) and Keyboard Maestro triggers to do all my Toggl stuff on my Stream Deck. Rock solid.