[Solved] Popclip & Applescript stop working

I have been using an Applescript to toggle Popclip on and off.
However, in the last week or so it seems to have stopped working. There have been a couple of updates to macOS.

The script I’m using is (triggered by BetterTouchTool);

tell application "PopClip" to set enabled to not enabled -- toggle

It will toggle Popclip on if it is off but won’t toggle it on. Has anyone else experienced this or anything similar? As I’ve mentioned it’s only just stopped working :question:

Did you try this in Script Editor?

I get error "Can’t make «class Pena» of application \"PopClip\" into type boolean." number -1700 from «class Pena» to boolean which indicates to me there is either a permission issue with the script status ‘enabled’ or something off in the dictionary.

tell application "PopClip" to set enabled to true


**error** "PopClip got an error: Can’t set enabled to false." number -10006 from enabled

So I think the issue is PopClips dictionary since enabled doesn’t;t appear to be a valid reserved word.

There was a new release yesterday that should have fixed it. See the release notes on this page:


I did try it in the Script Editor but I couldn’t decipher the error so your comments @lbutlr were helpful!

I completely removed Popclip form the system including the Accessibility in the System Preferences. It asked me to allow it (as usual) in Accessibility but then I had a popup mentioning Bettertouchtool. I was to busy on a clicking “Allow” frenzy to pay attention to what it actually said. However, the script is working again!

Could be removing it all or could be the update @sylumer mentioned.

I’m just glad it’s working again! :+1:
Thanks guys :smile:

If you installed the latest version it should absolutely be that as the release notes reference this particular issue. :man_shrugging:t2:

Ahhhhh didn’t realise it specifically mentioned the issue! That’ll be the fix then :computer: