SOLVED! Blink cameras on Homebridge

I am VERY NAIVE when it comes to coding, but i was able to follow some setup guides to set up my WeMo lights on home ridge so I can use them on HomeKit. I am having problems doing the same thing with my Blink security camera. I get the following error (see picture) when I try to run homebridge after installing the Blink plugin. I don’t have the slightest clue what to do to fix this. Can anyone help? Unfortunately I would need step by step instructions because I am at beginner level with this stuff. Thanks and apologies in advance!

Never used it before, but what steps did you follow to install the blink plug-in?

A quick Google suggests that one of the install steps is typically the failure point. Specifically one that looks something like this.

sudo npm install -g {name}

The output of that command is important as it details any install errors. As a result you would probably need to post those as well… which unless you captured the output first time around would mean repeating the process.

These are screenshots of terminal when I try to install the plug-in:
1st, I use npm I home bridge-blinkcameras (reference article for this setup online is here).


2nd, I followed the suggestion to run ‘npm audit fix’ and ‘npm audit’ (they both gave me the same results seen below).

Lastly, I also tried run-in the initial install command with ‘sudo’ in front as it suggested and it gave me this error:


When it comes to the ‘npm WARN’ lines that say no description, repository field, license field… I have no idea what I need to do there. The WeMo lights I installed did not ever show any errors like that, and since I know nothing about programming, I don’t want to mess anything up.

Any additional insight would be greatly appreciated!

The instructions note that there’s a dependency on you having node-blink-security and that would seem to match to the error you had. But the fact that it is listed as a dependency rather than being included makes me wonder if you may simply never have installed that dependency.

Try npm install node-blink-security and then try reinstalling your blink camera package. See if explicitly installing the security package is what’s required.

By the way, warnings can be useful but are not errors, so I don’t think you need to worry too much about warnings right now.

I got the same error when attempting that:


So just to confirm that statement. You still get the first error about it not being installed even after doing a global install (the -g option) of the ‘allegedly’ missing module (ref. the original error screenshot; but you last notes it as an update rather than new - bad phrasing of the message?) followed by a global install of the bridge-blinkcmeras module.

I.e. Two global installs in order of dependency.

Sorry for the confusion. I get the same error message when running “npm install node-blink-security” as when I ran the “npm i homebridge-blinkcameras”. The error from the last screenshot I’ve posted is from after attempting “npm i homebridge-blinkcameras”.

You mention the -g option. Should I be putting this somewhere in my command? I have been having to place “Audi” in front of everything to make it all work, but maybe I should be doing something with the “-g” instead?

I apologize for my ignorance with these command lines and if at anytime you want to tell me to quit while I’m ahead, I completely understand. I am more than appreciative of your help though!

I got it figured out! I did have to have it installed globally with a -g included in the command. Everything worked perfectly after that! Thanks again for all your help!

Remember, you were not getting errors except at the start. What you were seeing were notes of vulnerability and the audit command was to be run to provide details. Not to resolve it.

The error noted something missing and Googlng indicated this was often because of a need to install the modules ‘globally’ using the “-g” option when installing.

When installed globally the modules can presumably correctly be seen by one another when being run by whatever account is running the process to serve the services that enable the camera to work.

Glad to hear it’s now working.

1 Like

I’m trying the same thing. But running into the same problems. I’m new to this. Can you give step by steps? What’s “-g” and how is it used?
So glad there’s a community here.