Siri shortcuts stopped working with HomePod

#1

Monday my Good Morning Siri shortcut stopped working with HomePod. The error message was that the Shortcuts app had a problem (not correct, the problem was in Settings app). Clicking on the shortcut script in the Shortcuts app continued to work as before. Telling Siri via HomePod to activate specific accessories (lights) continued to work as before.

After checking that HomePod and all my iOS devices were on the same network, after deleting and rewriting the Shortcuts script, I figured there was something wrong with the HomePod. So I reset the HomePod to factory settings and started from scratch – not fun and still no joy.

Finally, a google search brought up a solution from a reddit user.

SOLUTION: Go to Settings>Siri & Search and select your shortcuts. Then re-record the shortcut phrase to something different, save, and re-record to the desired phrase.

It worked for me, I hope this is of help to other frustrated Siri users.

0 Likes

#2

It didn’t work for me, my homepod always work with shortcuts for a while, then I always need to reset it again otherwise it stops working at all

0 Likes