Siri Shortcuts and Carplay

Has anyone else here had success running Siri Shortcuts through CarPlay?

I have a shortcut called Monday commute which is supposed to get driving directions to work in Apple Maps, launch Overcast, and play the latest episode of Mac Power Users, but the shortcut seems to hang up when it comes to the map directions part of the workflow. It works when not plugged into the Car, so I don’t think there is a problem with the Shortcut itself.

Are Siri Shortcuts not meant to work with CarPlay? That seems like it should be a no brainer.

1 Like

I use mine in the car no problem, but I don’t have any maps integration. I’ll try and make one like you have and report back after my trip home today!

1 Like

I’ve had this problem with using Google Maps or Waze in Carplay. Siri Shortcuts with directions only works if I unlock the phone first. If I don’t give a specific direction, both launch fine without locking. Apple Maps seems to work for me without unlocking though, even with directions.

This is what I did and had no issues.

1 Like

I will try it that way also. Because I had the same issue where I had to launch it from the phone. It couldn’t be locked and launch Siri via carplay with Apple Maps.

Thanks for the pic. I tried it that way this morning and got the same issue. I’ll try it on the way home with the phone unlocked and see if that helps.

Only seems to work with me when phone is unlocked. Even changing around my shortcut.

Shortcuts is not working with Carplay and IOS13 any more.

I may be wrong, but I thought that I’d read in a a couple of places that CarPlay triggering was included in the imminent 13.1 update along with trigger from HomePod, etc?

Hello guys,
I’m running iOS 13.1 beta and it is still not working. I have shortcut for deciding where to navigate and then I run “Run shortcut” action with appropriate Waze Siri shortcut inside. All works fine until I connect it to CarPlay Automation triger (CarPlay).

Two potential issues in my set-up.

  1. Not sure if I can chain shortcuts calls. I have Automation trigger calling “Run shortcut” “Navigate me” inside which I have “Run shortcut” action calling waze. First runs OK; second - NOPE.

  2. Waze shortcuts simply don’t work when using CarPlay.

OK - tested with different trigger (time based). Nesting Run shortcut actions is no problem.

iOS 13.1 fixed issue with "open garage’ shortcut. Open and close without problem while connected to CarPlay or without connection.

Yes it is included (but I’ve not tried it yet).
For everyone: I had troubles to find it at first as it’s not available in the Scripts section for “when” conditions etc. You have to go to the “Automations” tab and then add a new Automation => Personal Automation => CarPlay

Can you share what shortcut you are using to open and close your garage? My shortcut will not run on Carplay or my Apple Watch and I’m running the latest iOS 14 and watchOS 7.