Shortcuts won't use updated contacts information

Is it by design that you have to re-add contacts to the shortcuts database in order to update them? What a pain that is.
I have a phone call list for people at work that pulls them from the contacts app.
If I update the contacts app the modified information is not listed when running the shortcut, ever.
I have to re-add all the contacts into the shortcuts script in order to show the updated information.
Is this by design or did I forget to perform some magic to make this work?

1 Like

It is definitely possible to get the current phone number from the contacts list at runtime. Without seeing how you are accessing your contacts from Shortcuts, it isn’t possible to say why you are having the problem, but here is a screenshot of one that does what you ask.

Hope this helps.


If you could share a (sanitised) version of your shortcut, even as a screenshot, it would be much easier to pinpoint where the issues might be :slight_smile:

Thanks, all. I’m no pro with shortcuts, and this is pretty basic as far as the overall steps.
Here’s the shortcut. Notice the blurred out section at the top. To the right where the plus is, you add in as many contacts as you want on that list. Perfect, ok. So, if you add the contacts and save the shortcut and test it out, it should work as designed. Great. Now open your contacts app and change something in there, like the phone number from (111) 111-1111 to (222) 222-2222. Now run the shortcut and the number will still reflect the old number for the contact.

In your first box, you are adding the contact to your Shortcut with the details (phone number) as it is at that time ie you are holding all the data within the Shortcut. The Choose from Contacts is selecting one of the items in your list and then the Get Phone Number is getting the phone number from the data that you imported when you created the Shortcut. You are not putting a call out to the Contacts app at any stage. Effectively, you have imported the names and phone numbers into the Shortcut as they were when it was created.

This Phone Test Shortcut goes back to the Contacts app every time that a contact is selected and so gets the latest details. The names held in the Shortcut are purely text. I’ve commented the Shortcut, so hopefully it makes sense.

I hope the explanation and the comments in the Shortcut make sense.

1 Like

Thanks @Tony!
I understand the comments and I’ll have to see about getting it working. It doesn’t work with multiple phone numbers though so I’ll try and work through it.
Appreciate the help!


Oops – my bad! Linked to the wrong variable in the “Find Contacts”. Here Is a version that should work… Sorry about that.

1 Like

Oh my gosh - this is it!
Ah, thanks so much! Having the working example is nice for me to learn from. I appreciate you taking the time out to help a stranger.
I’m really green with it, but for stuff like this, a menu of people to call because of their multiple contacts is far easier than doing individual shortcut actions and I thought … “it can’t be that easy” when I made that prior menu.
So I see the mistakes I made and this is pretty neat to illustrate what went wrong for me.
Now I can just modify the text of the names in the script. LOVE IT!!!
Thanks again, @Tony

1 Like

No problem. Glad it makes sense!

1 Like

Hey Tony!
Call chosen item at the bottom is what it gets stuck on after updating to iOS 14. Is there something else I should use?
It executes the action but it just asks me to choose a contact after I’ve already chosen one.

Can you share your Shortcut (sanitised) so we can have a look at what is going on?

This link should show you, I hope. Thank for your help! I guess iOS 14 has a little change it doesn’t like.

Hi @orgitnized

Just having a quick look at the Shortcut, you appear to have Group selected in the contacts look-up action – this should be Phone Numbers.

Tap on the word Group and select Phone Numbers instead. This will correct the selection further down the Shortcut as well where Group is currently shown.

Hopefully this should fix it for you – it otherwise works for me. If this does not solve the issue for you, let me know and I’ll have another look.

Really weird. I swear I never changed that but it worked in iOS 13. It works now!!!
Thanks so much for your help! You have a PayPal or something I can give you something for your time?
Thanks again, Tony!

1 Like

Glad that it’s fixed. Thanks for the offer, but we are all helping each other. Sometime you will find a question rhat falls in your experience and you can pay it forward.

1 Like