Shortcuts that use 3rd party app need to have 'Wait' for some seconds to complete successfully

I’m having an issue.

I’m running a pushcut server on an old iphone that is always up and running and the pushcut server is always on.

I’m using the shortcuts URLs to make calls from homebridge, the shortcuts are running a MiHome scene, to turn on a light or a TV or such.

The problem that i’m seeing is that when the api URL is being called - the pushcut server receives the call and executes the shortcut but the MiHome app isn’t doing what it suppose to do.

When i run the shortcut manually everything works.

I’ve tried to put a sleep (Wait for 3 seconds) in the shortcut - and this makes it more reliable, but the response is slow and i wanted to consult this forum to see if there is a better solution.

Any tip would be appriciated.


this sounds very strange, and I doubt Pushcut itself has much control over this. (all it does in this case is telling the Shortcuts app to run a shortcut)

it is just too weird that it works (better) after a delay…

you could try contacting the MiHome developers - maybe they have an idea what could be going on?

Is there something about Pushcut Automation Server’s thread model that could cause this? Like a lower priority thread.

not really.

the shortcut is executed by the shortcuts app - there is no way Pushcut can influence the internals of the Shortcuts app.

the only thing I could think of is some type of memory issue - where Shortcuts is does somehow not “take” enough to run this action…

but, given that

  • iOS manages memory quite aggressively
  • Shortcut actions are super limited anyway
  • Pushcut does not exactly take much
  • and Shortcuts - after a delay - seems to be able to execute it without killing Pushcut
    …it does not really make sense either…
1 Like