Shortcuts not able to use current song. Am I alone?

When I try to pull my current song with a shortcut to extract the lyrics. And I run into an error that tells me the song can’t be exported. Is anyone else seeing this issue?

Same here. And add current song to playlist doesn’t work too - was like that since the last updated Workflow version so I suspect it’s a carry over

1 Like

I can get the song and some details, but no lyrics from the couple I tried.

As per the output, the first thing to check is obviously that the song really is on your local device. Can you play it when aeroplane mode is enabled?

Try repeating the Get current song step. It works for me.

I’m still not having any luck!

But you can play it in aeroplane mode as I queried. Right?

Yes. It can. I find it so weird.

Next thing to try then the is a clean start to rule out any oddities for the device or the file. Given everyone else isn’t having the issue, that would statistically suggest it is something localised for your device. Though I do acknowledge that there is another poster having the same behaviour so it could be something wider.

  1. Pick a song you’re having trouble with. Delete it from your device.
  2. Reboot your device.
  3. Redownload the song.
  4. Start the song playing in the Music app.
  5. Retry your single step - Get Current Song - Shortcuts app custom shortcut.

Another question too. Do you subscribe to any Apple Music services? I don’t. Just wondering if there’s a service behind the scenes intervening and causing issues here.

I do. It wouldn’t surprise me if Apple Music was the issue.

I’ll reboot and see if I can isolate the problem.

OH, I have constant problems trying to play specific music from Siri. I tried to duplicate a script someone wrote that played "Never Gonna Give You Up” and it would only play “Shine” by Collective Soul.

As for getting lyrics? No, that never works whether the song is local or not. I suspect it is APple Music subscription messing things up.