Shortcuts always appends .txt to any File bookmarks created in Shortcuts

I think the issue here is Shortcuts and not Scriptable, but here’s what I’m fighting:

On iOS 13.3 developer beta, I am trying to set a file bookmark from inside Shortcuts to a folder or file (I’ve tried both). The problem is, no matter what path I create in Shortcuts, either .txt gets appended to it (in the case of the folder bookmark attempt) or the file extension gets changed to .txt instead of what it was (in the case of the file bookmark attempt).

The following images illustrate this.

Update, it’s definitely not a Scriptable issue, but it is a Shortcuts or iCloud Drive issue. If I use ShellFish inside of Shortcuts to save the file to a server, the file extension is preserved. But using the File Save or the Scriptable File Bookmark functions in Shortcuts always results in a text file having a .txt extension regardless of what I tell it I want.

I don’t have iOS 13, but there was a problem in iOS 12 that saved files with the .txt extension in the Save File action. A workaround was to set the filename with the corresponding action and not in the Save File action. But I don’t know how that should help with the file bookmark…

When you say set the file name in the corresponding action, what do you mean, exactly?

Thanks!

Like this

1 Like

Mind. Blown. How did I not know that? I bet that solves both problems!!

Thank you!

By the way, that Set Name trick does indeed work for both saving a file directly from a Shortcut with the correct extension, as well as creating a File Bookmark in Scriptable from within Shortcuts.

You completely solved my problem! Thank you!

1 Like