Shortcut not running from share sheet on iOS 15

I’m wondering if anyone can help troubleshoot this shortcut that used to work prior to iOS 15 and now does not reliably work.

https://www.icloud.com/shortcuts/ec82a637770848c39ef4c2b4063f0977

Basically, it’s a customization of a shortcut shared by Matthew Cassinelli for Twitter. Sharing a tweet to the shortcut should output a Draft with the text of the tweet. Used to do this great. Upon installing iOS 15, pressing the shortcut in the share sheet results in nothing–no error, doesn’t open up shortcuts, just nothing.

I created another shortcut just to test that I could fire a shortcut from the Twitter app share sheet. Works fine. Then I rebuilt this shortcut using simpler steps–seemed to work fine for a time, but then stopped working just like this one. Then this one started working again for 1 or 2 tries. Then stopped working again. Seems like it could be shortcut bug, but mostly I’ve heard about bugs in creating shortcuts, not bugs in running them.

Thanks for any help!

1 Like

I’ve been having this issue with many shortcuts being run from the share sheet. Sometimes they work, sometimes they don’t. It isn’t fixed in the 15.1 beta either. It is very frustrating and I don’t think there is anything you can do as it appears to be a bug in the iOS. Restarting the phone seems to fix it until it stops working again.

At this point I’d put any oddity in Shortcuts down to a bug. (I have one or two as well, including a strange new “file not found” when no files (as I understand them) are involved.)

I just hope there’s a “get well” focus for Shortcuts in Apple.

Have you tried having a look at the data type of your (magic?) variable where the error occurs (tap on the variable and have a look at the Type field in the pop-up)? I have had a few where the type has been changed to File (in a Shortcut that has been working for a long time and I have not edited recently). Change the type back to what it should be and hopefully the Shortcut will start playing again!

Hope this helps.

1 Like

Yeah, here’s hoping shortcuts gets a healthy dose of big cleansing soon.

2 Likes

FYI: a recent iOS update seems to have resolved this issue. The shortcut works now without problems.