Screenshot shortcuts, Broken?

Is it just me, or do screenshot not work with shortcuts? If I use the share sheet while making a screenshot and pick a shortcut, ie something that uses quick look on the shortcut input, it says nothing was passed to the action. Is my device just acting odd, or is this “normal”?

I have a shortcut that uploads a photo to Dropbox and turns the Dropbox link into a Markdown link. I was pleasantly surprised to find that it works just fine using a screenshot, without first saving it to my camera roll. I haven’t tried using QuickLook — maybe that’s the problem? (Actually, my shortcut does use quick look, but after uploading.)

Hm. I just made a one-action shortcut, usable from the share sheet, that just uses a Quick Look action. I took a screenshot of my phone’s home screen and used the share sheet action. It worked perfectly. Maybe try that, to see if the problem is somewhere else in your action instead?

Do you have your shortcut set to accept photo’s and/or pdf’s?
I tested mine, and they are all working for screenshots

I guess I do have some sort of system bug. I just tried again on my iPhone (was iOS pro before) and got the same result.

PS yes I took a screenshot of a shortcut of a screenshot🤨

1 Like

can you share the shortcut?

I can,

I’ve also tried this, does not work for me either.
Have tested all other screenshot processing shortcuts: same result; so seems definitely broken

So it’s not just me? Did you also try changing what it processes the shortcut input as? If I change it, it disappears from the parameter. Somethings up; Radar time