Saving a PDF to Dropbox


I’m having trouble saving a PDF that’s downloaded in Safari from a website I have to log into to access to my Dropbox. I’d like to know if anybody would have any tips for me?

The PDF is basically my payslip and other pay documents from work.

It displays fine in Safari, but if I use the Share button and choose Dropbox from the bottom row, I get the error “Couldn’t save content - please check your internet connection and try again”.

I can choose the Dropbox share extension from the top row, but then I actually have to share the file with somebody - I’ve been putting my own email in there as a workaround currently but that’s far from ideal :man_facepalming:

I’ve also tried with the Save File action in Shortcuts, which successfully saves the PDF to Dropbox at the location I choose, but the contents of the PDF just say “Authorization has been denied for this request”.

Does anybody have any ideas?! Thanks in advance!


1 Like

Are you logged in to the Dropbox app on your device?

Try the Copy to Dropbox action which should be on the top row.

is it a new device? Maybe you’re above the new 3 device limit?

Yes, I am.

I can’t believe I’ve never seen that before?! Thank you :laughing: That does do what I want, although if it could be done through Shortcuts without having to open Dropbox (and automatically selecting the destination folder etc) that’d be even better. Any ideas why the PDF doesn’t get the content saved when trying via Shortcuts?

I wasn’t aware of this new limit until setting up my new phone today, but no, I’m not over that limit anymore. I had the same issue on my old phone too, before it warned me about the limit.

You say the PDF content is the denial message. Can I just check this is the only site this occurs on?

For example, what happens if you try your initial approach with this PDF from Apple? Same authorisation issue or not?

I’m just trying to figure out if this is an authorisation issue with the web site or with the Dropbox interaction. I currently suspect the former.

Yeah it’s definitely something related to having to log in to the website first. That PDF worked fine. It surprises me, because Safari has already authenticated and downloaded the PDF as it’s showing it to me in the browser, and I can print / open in iBooks / etc. I just want some way to manipulate the PDF in a Shortcuts action!

Here’s all I see in Dropbox after the PDF has been saved:

Yeah. Because it is the web site, iOS needs to cache a local (authenticated) copy before it hands off. I strongly suspect your PDF is dynamically generated (you can probably tell from the source URL) and so when another (I authenticated) request is received you get a different PDF. Hence why the copy to works and the others don’t.

That’s along the lines of what I suspected. The URL is something like /api/Document/9374915.

If the “Copy to Dropbox” action is able to use the locally cached copy without any additional requests, is there a way for Shortcuts to do the same thing?

I don’t believe so as I think it is the triggering of that particular share sheet action that instigates the caching so that it can be copied.

You could try selecting the “print” option then using the same gesture as in Mail to expand it and share it; sometimes that works better for me but might take too long for what you want to achieve (or you may just have the same result…)

What gesture do you mean? I’ve not seen a way to share something from the “Print” action!

I think it would be this:

  1. Select print from the Share Sheet.
  2. (Long) Force press on the page preview to open a PDF version.
  3. Use the share extension from there.
1 Like

You learn something new every day! I didn’t realise you could force press on the page preview.

Unfortunately, Shortcuts gives me an error: “Conversion Error Save File failed because Shortcuts couldn’t convert from Extension item to Text.”

Actually I was using the ‘zoom in’ gesture (two fingers) but if that works too, that’s great. :joy:

That sounds more like an error in the Shortcut—the error reads like you are trying to save the PDF as a text file (though if so I’m not sure why it would have worked with the file @sylumer linked) ? Maybe if you were to share it (with anything sensitive removed, obviously) we could take a look?

I can’t easily share that particular PDF, but if I use that same “print then share” approach on the Apple PDF above, I get the same error:

Here’s a poor quality screencast of what happens:


Hmmmm. From the print page for that Apple PDF, a one step save to Dropbox Shortcut actually works for me.


Maybe try a device reboot?

1 Like

Huh, that’s really odd! A device reboot hasn’t helped, either.

FWIW, perhaps try my one step Shortcut.

If it works, perhaps try rebuilding yours based on this one.

If it doesn’t work maybe try signing out of Dropbox on Shortcuts. From the Save file action with a Dropbox selected, tap on the greyed out icons at the top of the Dropbox logo (top right). Select sign out in the dialog box that appears. Then sign back in and re-try.

There was a similar’ish bug for the share sheet a while back to do with images; so i guess I should also say, please ensure that your version of Shortcuts is up to date.

Similarly, because this is an extension thing, I think there could be some memory limitations that could come into effect. I’m assuming that you are using a relatively modern iOS device (i.e. plenty of available memory), but please let us know if that is not the case,

Beyond that I can only think of app reinstalls as an option; but that would seem an extreme step and I would hope we can figure something else out before trying that.


Still doesn’t work! Even after signing out of Dropbox in Shortcuts and back in - same error.

I’m using a brand new iPhone XS, so there shouldn’t be any memory issues.

I’m on iOS 12.3.1, which I think is the latest? And Shortcuts 2.2.1, Dropbox 144.2.

I could try reinstalling apps, although as this phone is literally brand new they were all only installed a couple of days ago!