Rename file in a Working Copy folder problem


I’m using the Shortcuts app to save and rename a file in a WorkingCopy app repository (via the File Provider of the app) trough the new native actions of the Shortcuts app.

The shortcut is relatively simple: take a photo, convert it to JPEG, save it in a repository and then rename it then build the markdown line to insert the picture in a document.

The save and rename are successfully done but strangely:

  1. I got an error at the rename step that prevent the rest of shortcut to be executed. The error message is « Impossible to open the file ».

  2. the file name has the extension duplicated i.e. test.jpeg.jpeg

I tried the same shortcut to save/rename the file in a iCloud Drive folder and I didn’t get the error. So I’m wondering if anyone here have tried the rename action, maybe this is a problem with the File provider of Working copy.

I forgot to mention but the repository is quite large in terms of number of files.

Here’s the shortcut if you want to give a try. Shortcuts

Thank you


I contacted the developer of Working Copy and there’s something going on but he was kind enough to show me a workaround: setting the name of the picture before saving it so no need to rename it afterwards.

Here’s the updated shortcut: Shortcuts