Problem with Shortcuts Automation

I have a personal automation that runs a shortcut script to generate and email me my daily calendar. The automation is the based. It works perfectly if my phone is unlocked, but when the phone is locked I receive a notification from mail on my lock screen that says “Tap to Respond”. Once I click the automation it runs but doe snot if I don’t.

Any idea what is causing this?

1 Like

Can you share your shortcut? Without it everything is just a guess as to the response trigger.

Sure how do I share it on here

You have a typo in your original post. I think you mean “time based”. Please confirm.

I will note, perhaps related, that my working-in-iOS-13 NFC-triggered automation now in 14 and 14.0.1 requires a confirmation tap. I consider this a bug - and it might be the same bug as you’re experiencing, just with a different symptom.


I modified the from and to addresses, and it did send for me via an automation, but I did have to tap on a respond notification for the mail action to send.

I think that might be as designed, to prevent malicious automations from using your phone as a spam bot

1 Like

Well, that’s a reversion from iOS 13.

1 Like

Thanks I just rewrote to save a pdf to a folder and have Hazel print it.

I’ve seen various reports that you may have to remove and re-add the automation to fix this. Worth a try?

On a similar note, when I run shortcuts that accesses a URL (for example, getting the components of a web page to save them nicely formatted in DEVONThink) — I need to allow my phone to access that website EVERY SINGLE TIME. I can’t figure out if it’s a bug, a bad configuration or a “feature”.

Yes. Unfortunately my NFC tag is in my kitchen in SOxon and I’m now in Dorset for a couple of days. I think I should make up a card with test NFC tags on - to take wherever I am in the world+. NFC tags are cheap enough to do that.

+ When they said “Your Mileage May Vary” I’m sure they didn’t mean down to as little as this year. :slight_smile: :frowning:

1 Like

Contactless cards have a chip in them which can be pretty handy for testing purposes!

Any way to see which ones would work?

In the UK, all contactless payment cards have this logo on them.

Right. I’d forgotten about this @RosemaryOrchard. I shall have to have a play. But I go home to my “real” NFC tags today.

OK. Tested with my real NFC tag and the “dance” doesn’t seem to work. The only thing I didn’t do was delete the “menu” shortcut I created to be triggered by this tag.

This on 14.0.1.

(BTW I wanted to move that menu shortcut to my Production Shortcuts folder on iPhone and didn’t see a way to do it. iPad yes, iPhone no.)

Good morning. I’m new to this forum but I have searched for my issue so hope I’m not duplicating anything.

I am wondering if anyone has solved the ‘tap to respond’ issue when using NFC tags. My shortcut runs when I select it from my list of shortcuts and doesn’t show this notification. ‘Ask before running’ is switched off in the automation and I have tried toggling that to clear the issue but it is still present. The shortcut pulls data from reminders and calendar, presents it in a ‘Show’ pane and when I hit done, it opens Microsoft Planner for me. Any suggestions?

Thanks in advance,

Stay safe…