Problem running from Shortcuts

I have written a script that works fine from within Scriptable, but when running from shortcuts results in error IntentsErrorDomain error 1307 - I can’t find any references to that, does anyone have any ideas what it is referring to?

One for @simonbs I think…

I’ve looked into the issue. It seems that the reasoning behind the 1307 error code is not publicly exposed so I’m not sure why this error occurs. For now, I’m leaning towards some internal issue in Shortcuts but I can’t be totally sure it’s not something in Scriptable.

1 Like

Well, I wouldn’t be surprised, I’ve had a few flaky problems with Shortcuts so far. I may just have to wait for updates to see if it gets better. My script worked fine on Sunday, but I made a few tweaks to it’s results and I started getting the error. I tried taking out my changes but after that change I get the 1307 no matter what I’ve tried.


I just got this error running a scriptable script inside a shortcut, I think the issue was a poor internet connection. I was between WiFi networks when it happened, then when I got a solid signal it ran fine.

1 Like

I don’t think that was my issue, I was at home and at work on good connections. The error does seem to have gone away, so maybe it was something Apple fixed on the back end.