Overlay Image Shortcut Oddities

I can get the Overlay image shortcut to work when I use an action to choose the image from the Photos app.I can have it positioned in one of the corners as required by turning off the option to show image editor. No problem to insert a calculation to make the size of the watermark be affected by the size of the main image.

If I send an image to be watermarked from the share sheet it only works if I show the image editor. That would get tedious with bulk watermarking.

I know the share sheet thing is working because the image arrives to the Overlay action and works when the image editor is switched on.

Is this a bug in Shortcuts with this action?

I used Magic Variable to set up the shortcut and I also did it again with the set variable action used and I had the same problem.

I tested that the share action was working by putting in a Quick Look action - It was working OK.

Here is my shortcut - https://www.icloud.com/shortcuts/df70773f02d14ef9bb595037f70a934e

As I was writing this I was testing again. A couple of times it worked from the share sheet. I’m baffled by what could be going wrong with this. I’m probably doing something silly somewhere…

Just sent this to Apple Feedback -

The shortcut works fine when I use the Show Image Editor in the action. The image editor pops up and I can position the watermark image where I want it. It runs to the end and gives me an image with a watermark which I can save to Photos if I want. - This is when sending images to the shortcut from Photos using the share sheet.

When I turn the Image Editor off so I can specify where the image is to be placed such as in a corner or centre or to specify a size… The app gives me a notification to say there was a problem running the shortcut…

I have tried changing the name of the file used for the overlay image. I have tried using set variables instead of magic variables. I conclude the action is broken.

If I run the shortcut from the Shortcuts app and there is no share sheet input so it uses the Select Photos action in the IF statement - The shortcut works as it is supposed to. No other changes were made.

There is a problem with the Shortcuts action. It will need a fix from Apple.
Seeing as no one has replied I’m guessing there is no work around.

I’ve just given it a quick try.

Works fine every time with smaller images. Gives me the error on larger images only, but consistently. That points to the usual memory limitations issue that Shortcuts hits.

I added a Continue in Shortcuts App action in and that looks to allow it to complete even with the larger images.

This memory constraint issue has been around sine the earliest Workflow app days and often shows when working with large images. It use to crop up all the time when people were trying to build grid layouts. Composite images like this are in effect the same, but rather than placing the images side-by-side, they are being layered.


Thanks a lot…
It’s weird wee things like adding an action like that that make you both laugh and cry.

1 Like