OmniFocus TaskPaper shortcut with projects in folders

Hi all. Long-time listener, first-time question-asker :slightly_smiling_face:

I’ve searched but couldn’t find an answer to this, so sorry if it’s already been answered. I’m using the OmniFocus TaskPaper shortcut to add a bunch of tasks to a project when a Pushcut notification comes in.

The trouble is, my project is in a folder, and I don’t seem to be able to get the shortcut to find the project. I’ve tried referring to it by its name, its fully-qualified name (separated with /, \ and :), and I’ve tried referring to the project by ID, and whatever I do, the tasks always end up in the Inbox.

Is this a known limitation, or is there an incantation for referring to projects in folders that I’m not aware of?

Would love to know anyone’s thoughts.
Thanks so much!

I’m not familiar with the specific Shortcut you are referring to, nor am I using those two apps mentioned.

But I do recall being confused/frustrated when I first started building Shortcuts automations to discover the folders/files had to be in the Shortcuts folder in iCloud Drive to work.

Here I think “Folder” refers to OmniFocus’ internal structure, rather than a folder in a filesystem.

I just used the name of the project. No folders, but all of my projects are uniquely named so they are easy to reference like this.

In Omnifocus I have a bit of a structure around my lists. Here I’m going to test with something within Web Sites.

Then within my personal web site ThoughtAsylum.

Then within the actual site project for that site.

So that structure looks like this in OmniFocus - a project in a folder in a folder.


Now, when I run this shortcut…

It adds the new task to my project.

Hope that helps.

It might help to see what shortcut you are using, but in general:


IIRC, that will find the existing folder anywhere in the folder structure, even if it is nested. But I am not 100% on that and did not test it.

Is your shortcut using that url scheme to create the tasks/projects?

1 Like

Thanks all! I think @sylumer you might have it, as I was ignoring the “Name” field as it felt extraneous given that I’d already put the name of the project in the bit where it said “Project”… :wink:

I will definitely try using the Name field in the shortcut and leaving the Project field blank as in your example, and see if that solves it. I have a feeling it probably will. Thanks!