Odd problem with dictionaries

(second try, somehow the post got lost)

I am working on creating calendar templates from a JSON object stored in a file in iCloud. So I created a Shortcut that can create a file and add a template:


This seems to work fine. It reads the file and shows a list of template names before it asks to add a new template.

The second Shortcut should read the file, create a list of the templates and present a list to choose from.
I started off with the same actions, reading the file and presenting the content. However, when I try to extract the keys from the dictionary, just like the first Shortcut I get a totally different content (ProfileName, Tiff and such). No matter what I do, I always get the same content from a dictionary.

Here is a link to a test shortcut that presents the problem: https://www.icloud.com/shortcuts/e3ce13b089d3473ca9f75a922b796ae3

I am on iPadOS 3.2 public beta.

UPDATE: after writing down this text I tried it again and now the first Shortcut presents the same problem.
I’ve restarted the iPad, but no difference.

I even tried to put the contents in a text action and get the keys from the that, but no luck.

3 posts were merged into an existing topic: Dictionary actions not working any more in Shortcuts