Markdown to HTML not working when sending batch mail. IOS17

I have just discovered the glitch about markdown to HTML not formatting when adding to Send Email action. I did a World Cup pool last year and it worked fine then. But I guess now it no longer works since IOS 17. I do have Drafts but the markdown email only works manually and I need to send to over 50 recipients. I really don’t want to have to manual hit that button 50 times. Any work around for this? I do have Keyboard Maestro on my Mac if that helps. And just downloaded Text Workflow on my iPad.
Thank you,

I can help you with sending html emails. But not via Shortcuts. Does that matter to you?

I don’t believe there is any glitch - the Send Email action only accepts plain text for the body of the e-mail:


That’s been mentioned to Greg before. It would be good if we could get an option to allow this to be overridden.

You could install mutt (via Homebrew is easiest), and then use a script action in a repeat loop to send each of the mails.

Here’s some discussion on how you can do that.

Here’s the man page for further details.

Of course this all assumes that you can’t send the 50 e-mails as one single e-mail with 50 recipients. If you could do that, one click to confirm might be more palatable.

Thanks for this. Yeah it does not have to go through Shortcuts. Just last year I could send HTML emails through the Send Email action and it turned them into HTML automatically when I gave it markdown. I didn’t even use the markdown to HTML action.
And yes I could send it to 50 at once but prefer not to. I’ll give Mutt a shot. Thanks again.