MacSparky’s Shortcut to Sync DEVONthink automatically overnight

hi @MacSparky,

You mentioned on a recent episode of either Automators or MPU that you have a Shortcut to launch DEVONthink To Go every night in order to sync your databases (due to the iOS requirement that an app is active in order for syncing to happen). Can you share this shortcut or else explain how you have it setup? I envision something like (1) launching DTTG, (2) setting display brightness to something low (5%?), (3) waiting X seconds (how many?) until DTTG has enough time to sync/re-index, (4) re-setting display brightness to 100%, and (5) ending shortcut. When I have tried to implement this way, it doesn’t seem to work…



Did you ever figure this out? I haven’t been successful either.

Unfortunately, I haven’t! I setup an ‘Automation’ (in the Shortcuts app) to run a specific shortcut every night at 3 AM, but only if the connected WiFi network is my home network so that this doesn’t trigger when away from home. Weirdly I get an error on my iPad every morning saying that the automation failed because it could not launch DTTG; however, I don’t see this error on my iPhone. It’s really hard to tell whether it’s working on my iPhone though so my next step is to test it at a time when I can actually observe the workflow being automatically executed.

FWIW, here is the setup I’m using:



Would be interested in what you’ve tried without success so I don’t go spinning my wheels in the wrong direction!

And maybe @MacSparky or @RosemaryOrchard could weigh in! :slight_smile:

1 Like

I’d love to see any solutions anyone has come up to this as well, as this is one of the bigger frustrations of using DTTG. @MacSparky, any help here?

UPDATE: over at the Devonthink forum, user FlohGro is using this x-callback url in a shortcut:
Seems to work, but sounds like this is a maintenance routine, and is not suggested.

what do you mean by “maintenance routine”?

Not my language - See here

Other than getting past the lock screen, is your shortcut above working @nm1?