Is it possible to setup Aqara M2 Hub within HomeAssistant

I am trying the Aqara door and temp sensors with a Aqara M2 hub. I am now trying to add the Aqara M2 hub into Home Assistant but I am wondering it is even possible. From what I have ready it might not be possible without modifying the M2 hub with custom firmware, etc. So I am wondering if there is another way. Or do I need to switch to a different Aqara hub. Rosemary talked about using Aqara with Home Assistant a few months ago. But I am wondering if she did something special to get the Aqara hub working with Home Assistant? Like did she use a different Aqara hub instead of the M2 (USA) version? Or did she just use a usb zigbee stick directly with Home Assistant. If anyone has this information it would be appreciated

I’m using Zigbee2MQTT with Home Assistant (I was previously using the built-in ZHA), this required a Zigbee dongle (a controller) which replaces the Aqara hub. I’m using the SONOFF Zigbee 3.0 USB Dongle Plus with it and it’s working really well.

Thank you for your reply

I also have Home Assistant and a Zigbee dongle running on an always on iMac. It doesn’t look like you can have an Aqara hub as the primary point for the accessories, then have that configured to HA. Instead, it looks like you have to use one or the other (Aqara Hub or HA with Zigbee). Did anyone else figure this out?

I want to have my water sensors connected to the Aqara hub cause it’s less likely to go offline, but I also want those to show in HA. Looks like I can’t do that.

That’s correct, you can’t. But unless you do something to your Home Assistant machine, it shouldn’t go offline. Mine has been rock solid (and unlike the IKEA hub I don’t get Siri merrily informing me half my devices are unavailable whenever I try to run a scene—assuming those are paired to the HA dongle!).

1 Like

Thanks for the response Rose. I guess I should share my experience with Home Assistant. It’s been rock solid, BUT…

I run it on a late 2013 always-on iMac. When I’m logged in, it works great, but when someone else logs in and it goes to screen lock, it doesn’t work. Of course, should someone turn it off, that doesn’t help.

I know I need to get a dedicated RP for it and that would solve the issue. I want to get the Home Assistant Yellow, but it’s not available until November. Maybe I should look at something else or go for the Kit which is available the end of May.

I have an Ikea remote I’m using in HA and it’s great.

I’d recommend not getting a Pi (microSD cards are really a mixed bag and the last thing you want is corruption!). The ODroid N2+ looks pretty good, or you could look at any Intel NUC like machine (that’s what I did).

I went ahead and purchased a ODROID-N2+ Home Assistant Bundle. See you don’t only cost David money. :slight_smile: :joy:

1 Like