iOS Shortcut suddenly not attaching PDF or photo to email

I had a simple Send Receipt type shortcut that has been working perfectly for months.Now it (and a couple of other similar shortcuts) are not attaching the PDF to the email. Basically the shortcut would ask for the name for a receipt, then open the rear camera, take a photo of the receipt, convert it to a PDF and send it as an attachment with the name entered at the start as the PDF name. Now this is only sending the email but with no attachment. If I go into the editing mode I can see the image I have taken in the email body, but it no longer comes through in the email. Any idea why this might have suddenly happened?


It’s very hard to work out what’s going on without having your shortcut. Every suggestion would be purely speculative.

I tried this simple three step shortcut based on a simplified version of your description above. When I sent the resulting mail to myself, it arrived with the correct attachment as a PDF.

FYI, I’m using Shortcuts on iOS 13.3 (17C54).

I’ve had something similar happen to one of my shortcuts that store images.
Looking through the shortcut one of the variables was “greyed out” so no langer had input.
Would have to have a look at your shortcut to verify.

Thanks for the replies. I am new here, how can i post the shortcut for you to view?

It’s exactly the same way as sharing anywhere else. Open the Shortcut for editing, select the share sheet icon. Select copy iCloud link, paste the link into your post.

If it has any personal information (e.g. a personal Email addresses), duplicate the Shortcut, remove the information you don’t want made public, then copy the link for that.

Dd the three step shortcut above work for you by the way?

Thanks for the help. Yes, the simple three step worked. The structure is slightly different to mine, but as I say mine used to work up until possibly 1OS 13.3. Here is the link. . .

Okay, based on a bit of testing, I’m thinking it is maybe a bug in the send mail action.

Try setting it to show the compose sheet and see if the PDF comes through for you then.

When I try the shortcut (configured with appropriate addresses for me), I get no attachment if show the compose sheet is off and I get attachments if show the compose sheet is on.

Thanks for your help. Yes, that fixed the problem. I guess I will just have to leave it on until the bug is fixed.

Cheers Rick

@sylumer I have attempting to set up your same three step system for sending receipts for my business. The variation I can’t figure out is how to send from my outlook email.

I want to take a photo, turn it into a pdf, and send from my outlook to a predetermined recipient (accounting dept) with a user input for the email’s Subject (which will be the unique job number). Any thoughts? Thank you.

Outlook is an e-mail application. If you are using Microsoft services for e-mail, then behind Outlook you will be using Microsoft Exchange.

If this is set up on your i*OS device as a mail account, you can use the actions exactly as above, just specifying the Exchange account for Mail by setting the from address in the Mail step’s settings.

So I was driving myself crazy here, I was trying to do this with Siri Shortcuts on my Mac and no matter what I did it never sent the attachment. Though if I do from my iPhone it works as expected, ah Mac Shortcuts is still just not there yet :frowning:

My shortcut is to send a PDF report to some recipients.

I remember being so excited they added this at WWDC 2021 and I think it might take to WWDC 2022 to actually have the bugs fixed :frowning:

Model Identifier: MacBookAir10,1 (M1)
System Version: macOS 12.1 (21C52)

I know this is an old thread, just saying this is still an issue and on my mac I just used this instead.

Actually, if you want to send attachments, you need to use mutt