iOS 15.4 update, Focus Mode Automation Now Stopping Until Tap to Respond Selected

Every since I updated to 15.4 an automation that runs when I turn on a focus mode now requires me to tap to respond in the Notification Center. The automation first sets the Home Screen, runs a timer menu selection, then opens a split view of a safari window and another app. It used to run fine, but now it’s stopping after going to my selected Home Screen and wont give me the timer menu until I go into my Home Screen and hit the tap to respond.

I’ve got it set not to ask to run and not to notify me when run. Any ideas what the problem is and what I can do about it? Is this just a bug?

Thanks for your help.

I use Focus modes multiple times a day and run an automation to switch home screens and some other actions. For me, these have worked without issue on 15.4.

Some ideas to perhaps try:

  1. Switch ON the confirm when run action, run it and then turn off the confirmation.

  2. What happens if you run the Shortcut from the Shortcuts app without switching the Focus mode?

  3. Create a different automation trigger to activate the Shortcut to test it.

  4. Try recreating from scratch the Focus mode automation trigger.

  5. The good old reboot your phone option.

  6. Make sure any apps that are being used by the automation are up to date.

  7. Insert some Quick Look or Show Result actions to work out exactly where things are stopping and what might be causing it. The new paid app Logger for Shortcuts is also helpful for this.

Hope something here helps.

And an extra step: What happens run you run the automation? Even if the automation is a “Run Shortcut” action you need to grant it permissions to run, which you can do by running it with the play button in the bottom right.

It’s a really simple automation. It opens a specific Home Screen, run a choose from menu timers shortcut, and then runs a split screen shortcut. When I run it from the Shortcut app, it works fine though it seems to require me to return to Shortcuts to continue to the next step. I don’t know why that is. I tried all of your suggestions, @Tony , and no improvement.

I rebuilt the automation and now it doesn’t even give me the tap to respond option. It just stops working. The automation worked fine until the 15.4 update, but then when they added the notify when run toggle, it stopped working without tap to respond. The 15.4.1 update hasn’t helped. The tap to respond is still there. I ran it and gave permissions to everything once I rebuilt it, so that’s not the problem. The individual shortcuts that I run inside the automation are working fine. And I deleted the go to home screen action since the focus already sets the Home Screen, but still no improvement. It always requires me to navigated to notification center and then hit tap to respond, and it didn’t used to.

When I build automations, Shortcuts seems to hang up almost every time before I can hit “Done.” Is that related, do you think?

I changed it to Ask Before Running and that seems to be easier to deal with than having to navigate to the notification center. It’s super frustrating when it’s working on minute and then the next it isn’t.

Maybe I’ll try again another time.

So it was working if I turned on “Ask Before Running,” but now again even with that on, it’s requiring me to go to the Notification Center to “tap to respond.” Shortcuts has been so buggy and slow ever since ios 15. Not trying to continuously complain; just thought I’d give an update.