iCloud Links Do Not Work

I’ve tried several different links that are supposed to be specific to Shortcuts on MacOS - none of them work.

First I am taken to the correct page on iCloud which shows the name of the Shortcut up top and has a ‘Get Shortcut’ link down at the bottom. Clicking on ‘Get Shortcut’ takes me to an itunes.apple.com link, which informs me that the Shortcuts app is only available on iPad or iPhone.

How do I open this in my MacOS Shortcuts app?

Can you provide an example link?

From my experience, any iCloud shortcuts link

Here’s the first one I could find on Reddit:

https://www.icloud.com/shortcuts/3a4f120da6ab4b2e8bd3bed2cb2e5774

If I follow that link on my Mac, Shortcuts opens, and I get the following window where I can select Add Shortcut, and that adds the shortcut to my library.

What version of macOS are you running? Shortcuts was introduced, as standard, in Monterey (macOS 12), I am running 12.0.1.

I’m assuming you must be on some version of Monterey given you refer to running a shortcut from Hazel in another recent thread.

Monterey 12.0.1

If I follow that link, it takes me here and up top it says “This app is available only on the App Store for iPhone and iPad.”:

OK, you are being redirected to the i*OS version of the Shortcuts app rather than to a URL that triggers the Shortcuts app already installed on your Mac. The Mac must be in some way being instructed to check for shortcuts being installed (either direct or implicitly) and be checking for that version rather than the native macOS version of the app.

  1. Are you using Safari as your default browser?
  2. Do you have any browser add-ons or web filtering services you are using that might potentially be affecting it?
  3. Is the behaviour any different if you try a private browsing session or different web browser?
  4. If you create a new vanilla user account on your Mac (for testing purposes), does that get affected in the same way? <= only do this one if the previous one gave you consistent failure across browsers and private sessions.
  1. Mainly Chrome, Firefox in the past. Rarely Safari.
  2. I have extensions, but it does the same even in an ‘icognito’ window.
  3. No, same in Safari.

By the way, this is probably important. Shortcuts does not exist in the Mac App Store. Is it just part of Monterey now?

From those points it suggests that the isue is outside your browser (as it affects all browsers regardless of browser profile, cache, etc.).

You have not listed any external services yiu are using, so I assume therefore you have none.

You do not appear to have tried the fourth test, so I cannot tell if there is an issue in the OS, or that is related to your specific user account. Hopefully, you will still consider testing that.

It is a standard app in Monterey.


When you are following an https://www.icloud.com/shortcuts/link, you are being taken to a web page on your Mac. When I follow such a link, it is automatically being passed to Shortcuts for download. I don’t know if this has to use Safari (or another browser) to initiate this, or if the OS is the key link. But, the initial behaviour is what is in error here. You should never get to the web page with the download link, you should just be taken straight into Shortcuts.

My best guess would have been some sort of plugin, VPN or security protection software intercepting it, but you don’t seem to have anything you think could affect the URLs you are following.

Out of interest, is there any change in behaviour if you try running this terminal command to open the URL rather than following the link from within the browser?

open https://www.icloud.com/shortcuts/3a4f120da6ab4b2e8bd3bed2cb2e5774

Would it matter if the Shortcuts app does not exist in the Mac App Store?

No, that command opens the same link in my default browser. Clicking ‘Get Shortcut’ takes me to the app store preview on the web, which informs me:

“This app is available only on the App Store for iPhone and iPad.”

If I go to my App Store app and search for Shortcuts there are no results. So why would any URL open up the Shortcuts app?

No.

Also no one else seems to have this issue.

If you had deleted the Mac Shortcuts app then maybe that would create this sort of behaviour, but your original post infers you have not.

There could be several reasons, but to me, the most likely is that Apple has embedded the association in the OS in much the same way as on the mobile OSes.

I guess this is a slight mea culpa…

I just created an iCloud link to my own shortcut and opened it in Safari. It works! I also tested one of the links earlier in this thread, it also works.

So that means that Firefox and Chrome don’t seem to understand such links even with all extensions turned off. I’m really surprised no one else seems to be having this issue. Puzzling…

Has something changed then? You explicitly noted earlier that the links did not work in Safari.

Thus, the mea culpa.

I did not knowingly change anything, so either something fixed itself or I was mistaken about having tested in Safari before.

The upshot of all this is that I’m giving Safari another test run to see if I can get it to perform close enough to Chrome/Firefox that I can justify using it as my daily driver.

1 Like