HomeKit won’t open pushcut URLs

Whenever I try to run a HomeKit shortcut with a Pushcut URL, I get a message saying that the server with the specified hostname could not be found.

Hi Jeff,

I have now received several reports like this, but I couldn’t figure out the reason yet. All I know is that it is not a general HomeKit limitation - I would even say it works for most people.

There were a few reports like this early on, where one assumption was that OS betas were to blame (like here and here) - but as I still keep getting the occasional report about this, I am not so sure…

If it does happen, afaik, It does not seem to be limited to Pushcut: URL resolution in general is funky then.

Also, one suspicion is that the Home Hub device type matters here: Are you running a HomePod as a hub by any chance?

In any case, all there is to do is reporting this to Apple I think. I might even try to make use of a “Technical Support Incident” ticket, but is tough to report an issue as “sometimes people say it does not work”… we’ll see.

I have 2 Apple TV’s, 2 iPads and a HomePod mini as hubs. It does seem to be every public URL that fails with this message.

Hi Jeff,
same here.
Please try to execute the shortcut not within the shortcut itself (were you can see the link).
Could you please retry this at the highest level within shortcut?
“Test Automation” and not within the shortcuts, where you can see the link. (sorry for my bad description).
Does it work now? - for me it solved my problem…

I have the same issue. Was working perfectly last week. But now, every Get Content of URL from a shortcut fails.

For info:

  • 3 HomePod Minis, 2 Apple TV’s (tried disabling/enabling devices to see if it was HomePod vs Apple TV issue but no change)
  • No iOS updates have occurred between working and failing state
  • Pasting the URL into a browser triggers the shortcut in Pushcut so the URL is well formed
  • All devices involved re-booted
  • Running the action from the ‘Test button’ yields the same results.
  • Nothing in the pushcut server log so the URL request is clearly not reaching Pushcut so is ‘stuck’ in HomeKit I’m guessing

If anyone has any suggestions, I’d welcome any thoughts

Hi mrplow,

have you already tried to execute my suggestions above?
Try to execute the whole shortcut within the shortcut App.
My suggestion is, that the HomePod Mini does not work like expected. Are the any differences between Apple TV and HomePod mini as a bridge? For me ATV works fine, HomePod mini not.

Please let us know how it works.


Thanks for the response.

As above, there’s no difference in behaviour between Apple TV and HomePod. Sorry if I didn’t explain that properly

If I create a ‘pure’ shortcut in the app to call the URL, it works fine.

Hi. New to Pushcut and just getting started. I have exactly the same problem as described above (and have a mixed environment of Apple TV 4K and HomePod minis, which seem to randomly share the task of being the hub between them). But in my case there’s an additional twist. On the iPad Pro I’m working on, when I test my notification in Pushcut app, all works well. When I paste the URL into Safari, I get a success message but no notification appears. Am I doing something obvious wrong or is this part of the same problem described above?

Ah OK got it now. Realise I wasn’t waiting after pressing ‘start server’ until it went into the ‘automation server’ screensaver type screen before it would process requests. Working now (at least from safari)

Can someone post a (a screenshot of a) sample of such a shortcut? (Do obfuscate the secret in the URL?)

Then more of us can see what we’re talking about - and think further on it.