Help with Shortcut that uses 2do app

I have created a couple of shortcuts that add new tasks to 2do, which is my current task manager. One of the fields is “Action”, which allows you to specify the action for the task (Visit URL, Send Email, Phone call, etc.). One of my shortcuts takes data in a line, parses it, and uses the pieces to fill the fields of the task. I can get the actions to work when the data I send is written correctly, but I can’t figure out what the data should be for the Action to result in “Send Email”. If the data says “Send Email”, the resulting task ends up having “Send Message” action, rather than the desired “Send Email”. Is this a bug, or am I doing something wrong?

Here is a sample shortcut that illustrates what I mean.

I tried replacing the 2Do Action elements use of a variable with selecting “Send Email” directly from the list within Shortcuts. It still gives message as the result.

I can specify it in the 2Do app.

Next thing to check would be if the 2Do URL scheme works for this or not. That’ll let you in now if the behaviour originates in Shortcuts, or in the 2Do implementation of the URL scheme.

Either way, this quick check makes it look like a bug to me.

I tried it using the URL Scheme and the information documented here, and it has the same result. Does that mean it’s a bug with 2Do? I’m wondering where I should file the report.

I’d maybe use the contact us page in the support area of their web site.