Help with a simple Translation Shortcut

Hi all, a friend asked me to help her with a problem using Siri Shortcuts: she wants to be able to dictate to Siri an English word, get the French translated back to her (in the French pronunciation), and then have both the English and French appended to a note for later study. She wants to be able to do this without having to touch or look at her phone.

Here is what I have made: Shortcuts

The issue I am running into is this: I get the French pronunciation when I run it inside the Shortcuts app, but when I run it via triggering Siri (on the lock screen) I get a different voice (English) that tells me the French word in an English accent.

Do you know why this is happening and if/how I can fix it?

Thank you!

I haven’t been able to get Siri to understand or speak more than one language at a time. It seemed that you’re forced to choose a single language for Siri. If you find a solution, I’d like to know about it.

1 Like

Check your keyboard settings. You may have to have language installed in keyboard and then pick your accent. I’ve written many specific shortcuts for translation but even without these : If I ask sri ´what’s ‘work’ in French - Response is: Work in French (UK accent) is ‘travail’ in French accent.

1 Like

I checked your shortcut. It works fine so must be keyboard
These might help your friend (you may want to combine)

1 Like

@Gryff Thank you, both. I was out on vacation so just getting back to see your responses. I appreciate them. @Bulsara - I will look into the keyboard language setting and the shortcuts you sent.