Google maps not loading directions from apple's shortcut over carplay

Hi there,
I’ve created a shortcut that loads google maps with to-work directions (retrieved from Calendar) triggered when phone connects to CarPlay.
It worked fine for the first one or two days… then It just opens google maps but no the given route.
When using Apple’s Maps instead, it works fine. But early It worked fine with GMaps.
Apple’s Maps is not updated in my country so it’s almost useless.

When running the shortcut directly on my phone, it works as intended: the route is loaded into GMaps and ready to go.

I’m a bit lost. Any ideas?


I’ve ran into a similar issue before.
I have a separate shortcut called navigation that will be passed an address. Then take the following steps.

Open Google maps.
Wait one second
Send the address to driving directions Google map.
Save the address to a data jar Keyed to “Current location”

The only reason for saving the current location to data jar so that I can have quick reference to the location I am supposed to be at for other automations to check against.

It seems that if the Google app is not up and running already, sometimes it will not receive the input for driving directions upon startup. So if you open the app first wait for it to churn a little bit on it startup and then send it the location it performs more consistently.