Encrypt and upload file


I have a zip file in my iPhone with somewhat sensitive information that I want to upload to Dropbox encrypted. Is there a way to encrypt a file in shortcuts (even using a third party app) before uploading it?


Zip files can be created with a password, which can provide reasonable encryption if done with security in mind. But this is an at creation step, not after the zip file is created step. How/where is the ZIP file being created?

Are there any requirements for decryption? Such as it must be decryptable by someone else on some other platform and you might not be able to dictate what nOn-standard tools they can access. This might dictate/preclude other secure container options such as Boxcryptor.

Hi @sylumer,

The file is already created. My shortcuts renames it to something more sensible, and I just figured out I can use cryptomator to upload to a safe vault in dropbox.

Interestingly, if I try to upload the file directly from the share sheet, cryptomator shows up as an option. But if I instead run it through my renaming shortcut and try the ‘share with extension’ option to copy the renamed file to cryptomator, the latter doesn’t show up in the share sheet. Any ideas?

That all depends on what your renaming shortcut is doing, and ultimately offering up at the end. You can use the get type action to determine what is being passed. I suspect it needs to explicitly be a file, but I’m not a Cryptomator user, so I can’t verify any particular behaviour.

The input and output of the shortcut is “file” type as I expected. I’ve tried it with other files and what the “share with extensions” action shows is different if I pipe any file directly through the share sheet vs my shortcut, which doesn’t seem to make sense.

There are different share actions in Shortcuts. Try the Share action for example, or Open In....

I think the problem here is that you use the Copy to App feature rather than an extension, but only extensions are listed with the Share with extension action.

Hi @schl3ck, yes using “open in…” worked, as it showed me a share sheet with the Cryptomator option added.

How would a regular user know this?

Thanks to both of you, problem is sorted!