Default Date & Time Not Working

I am having an issue where the default date/time (depending on shortcut) is only showing the current date/time. Is anyone else having this same issue?

Thanks in advance!

Sorry, but that reads as rather vague to me. As it stands there is not indication of what actions you see this impacting, with what defaults, and under what circumstances.

Can you share a link to an example shortcut we can download and try that is using the current dat/time, but where you expect it to be defaulting to some other date/time?

I sure can. Please see the link below.

Invoice Email

Looking at the shortcut, the Ask for Input action is supposed to have a default date of 2 weeks ago (calculated above it). However when I run the shortcut it is showing a default date of today.

Thanks for the help!

I’ve tried the Ask For Input action, and while the text, number, and URL formats seem to work with the default, none of the ways I tried setting a default (including the output of one prompt into the next) worked for the date, time, or date and time options.

However, it looks like I haven’t had the latest OS updates pushed to me (Mac or mobile), and this Reddit thread suggests the latest update resolves this.

I’ll try force updating in a bit and see if I get better results. Might be worth you trying too if you are also not on the very latest and greatest.

I’ll do the same and post what the results are. Thank you!

Looks like it worked after the software update on my iPhone.

Same here. Thank you so much for your help!