Data Jar not syncing on new iPhone

Good evening. I setup a new iPhone today. Data Jar is not syncing. Any tips on how to troubleshoot?

Other apps that leverage iCloud synch seem to be fine. — jay

Open settings in Data Jar and select Sync Health.

What does it show?

I should have included mention of that. It"s healthy with all checked as ok.

In that case try a reboot then, if it still has issues, a reinstall. Still not right, try signing out of iCloud and back in.

After that I’d suggest contacting Simon. It isn’t a day-to-day app issue as far as I’m aware.

I’ve done all of the above already. (Including message to Simon). Thanks for the response… thought maybe there were other troubleshooting techniques.

Still trying to sort this one. No response from the developer. I just noticed the following in the sync log. Is this meaningful in terms of things I might be able to troubleshoot?

2021-01-28 10:15:06.290-0600 [App] [Info]: Will fetch changes from CloudKit.
2021-01-28 16:25:28.433-0600 [App] [Error]: Did fail fetching changes from CloudKit: Couldn’t communicate with a helper application.

@simonbs - any ideas on what this issue with Data Jar sync could be?

I don’t recall seeing the “Couldn’t communicate with a helper application.” error before. It’s coming from somewhere within CloudKit.

@jayelevy Did you use Data Jar in Shortcuts just before this error appeared? Can you try to quit the app from the multitasker, reopen it and check what the log says? I’m curious to know if it gives the same error when trying to sync from within the app.

@simonbs thanks for the response. I have not used Data Jar via Shortcuts on this new phone. The only thing I’ve done in DJ on the new phone is manually create an entry to see if it would synch to my DJ store accessible on other iOS devices. It didn’t.

Per request, I just quit the app and relaunched. Here’s the current log. The entries from yesterday were from my 3rd or 4th time I’ve deleted the app, signed out of iCloud, signed in and reinstalled. Hoping that would resolve. It didn’t.

[{"message":"Will fetch changes from CloudKit.","level":"info","bundleIdentifier":"dk.simonbs.DataJar","date":"2021-02-02T21:14:49.390-0600"},{"message":"CloudKit zone created.","level":"info","bundleIdentifier":"dk.simonbs.DataJar","date":"2021-02-02T21:14:49.511-0600"},{"message":"CloudKit zone created.","level":"info","bundleIdentifier":"dk.simonbs.DataJar","date":"2021-02-02T21:14:49.663-0600"},{"message":"Will fetch changes from CloudKit.","level":"info","bundleIdentifier":"dk.simonbs.DataJar","date":"2021-02-03T08:09:51.338-0600"}]

Posting resolution here, in case someone comes back to this thread. The root cause is unknown, but the problem was resolved by resetting local storage on the new iPhone. Settings → Sync Health and then tap the cloud in the lower left corner. Once that sync completed, all data moved to phone.

1 Like

Back again. Setting up new iPad. Very similar issue as described above although this go-round the reset local storage option is not available. Would welcome any new tips/guidance that may have emerged since my prior post earlier in the year.

Will continue working on iPad, but I’m out of troubleshooting steps.

I’m thinking it may be time to migrate my database dependent shortcuts to an alternate and more standard data storage framework. I’m not really interested in investing that time, but it’s looking like it may be a worthwhile investment for long term stability and dependability.

I tried to run a simple one line Shortcut to write a value to Data Jar on this new iPad. Doesn’t work…timed out. The operation works when I turn on Airplane Mode, but not on wifi.

Posting my final resolution in case someone comes to this post.

I migrated my database dependent Shortcuts to the Global Variable capability within Toolbox Pro. A simple 2 step Shortcut handled the migration of the data and I had to make a few minor modifications to the impacted Shortcuts. In all, it was an easy switch. — jay