Confused by Shortcuts & x-callback

Hi all. I’ve built a shortcut that mostly takes a lot of steps to create a URL for one of two apps (Tot and NotePlan 2) depending on the input. Once the URL is built, I want Shortcuts to use it to open the correct app.

The resulting tot:// and noteplan:// URLs work — I’ve tested them from a browser, and also I can get the shortcut to run and execute one URL. However, once that URL is done, I stay in Tot or NotePlan, I don’t go back to Shortcuts.

If I open Shortcuts manually, it’s clear the shortcut is still running (though there are no more steps). This is weird, but works if I’m just creating and running a single URL.

But of course I want to do several at once (using text input that’s split into lines). Now the first URL gets built and executed, but I still get stuck at the receiving app (Tot or Noteplan). If I manually return to Shortcuts, it processes the next URL and sends me to the appropriate app, where I get stuck until I return to Shortcuts manually.

I’ve tried using the Open URL shortcut step and the Open __ with x-callback step (with various settings for the latter). Same behavior every time.

Clearly I’m missing something. Or is this the expected behavior? Help!


1 Like

URL schemes are not equivalent to x-callback-url. And it’s the latter that enables the callback. The developer has to add in code to process the additional standard parameters an x-callback-url should have that then allows it to pass control to the next URL in the chain - typically a return to the original app with the URL loaded with result details.

Some automatable apps allow you to fake it by programming in the processing yourself, but there are relatively few of those.

I think you are simply working with apps that have registered URLs/schemes, but don’t have support for x-callback-url.

Ah. I was afraid of something like that. I may also just be sending it the wrong callback argument. But now at least I know there may be no solution — it isn’t necessarily my innate boneheadedness. Thanks!