Can't run any Shortcuts from Share sheet on iPad OS

I have a brand new iPad Pro running iPadOS 3.2. Every time I try to run a Shortcut from the Share Sheet I get the following error message: “Could Not Run Shortcut. The shortcut couldn’t be found because its access token has expired.”

The error occurs whether it’s an old Shortcut that it inherited from my old iPad or a brand new one I just created on the new iPad. All the Shortcuts run fine on my iPhone.

The only thing I could find on a Google search was a Reddit reference to a bug in iOS 13 beta 1 that was fixed in beta 2.

Any suggestions?

In case anyone is wondering, the new update to iPadOS 13.2.2 fixed this problem for me.

1 Like

Great to hear the problem has been solved for you :smiley:

1 Like

I have had the same problem and I am using 13.2.2. Any fixes welcome!

I’m having this issue and have updated my iPhone 11 Pro to 13.3. Pretty frustrating as I had come to rely on a couple of sharesheet Shortcuts.

I’ve tried restarting the phone. Any other ideas?

A few thoughts:

  • Check to see if only for particular sets of share options (images, text, web pages, etc.) There may be an extra clue there.
  • Does it work if you manually build a new version of a shortcut?

There may be a shortcut to fixing your shortcuts depending on the exact pattern of behaviours. Otherwise it would be a case of not tackling the data but the app instead.

Assuming nothing positive from the above, you might then focus on the Shortcuts app. First approach here would be to offload and then reload it. Failing that, a forced removal and then a reinstall from the App Store for what may or may not be a cleaner reinstall. In each case you would re-sync your shortcuts from iCloud and re-try for the error.

After that I’d imagine it might be a factory reset. Now that Shortcuts is baked at some level into the OS, it’s harder to determine if the app component or an OS foundation component is the bit that needs refreshing to fix the issue.

Hope that helps.

1 Like

Thank you! Yes, in fact about five minutes after posting (just long enough for me to forget that I should come back here to add my solution), I stumbled on the suggestion to offload and re-add Shortcuts. That worked like a charm!