Cannot set calendar event to open file

I am trying to create a calendar event that opens a file at a specified time. I add the event, select the custom alert and open file. It all looks good and then I add the event. If I go back to it, all of the alert information is lost. Does this function work for others?

In order to test accurately can you perhaps fill in some more detail?

  1. What platform is this on?
  2. What are you using to add the event? An automation tool? Manually via some native calendar app? Via a web app,?
  3. Can you provide an example screenshot to show us how and where you are adding the “open file” link/info/parameter?
  1. MacOS Mojave (v14.6)
  2. Manually adding the event into iCal

It gets added and then if I go to look at it, the alert info is gone.

I tested on Catalina (10.15.5 (19F101)) using a text file. I could open and reopen the settings, and they remained intact. The file opened at the allotted time too.

Any chance you haven’t tried a reboot? More weird issues have been resolved by a reboot than anything else :man_shrugging:t2:

Failing that, you could try some of the suggestions in this discussion, like repairing permissions, checking basic creation details stick when entering into your calendar (via perhaps?). There’s a more drastic option earlier in the thread too; I’d try the others first.

Hope that helps.

I have now tried on 3 independent systems (including a reboot) with all running 10.14 and in all cases the custom alert disappears and no file is opened.