Basic troubleshooting tips, pls

Hey folks.

Anyone got an IFTTT recipe running to kick off an iOS shortcut via Pushcut, by chance?

I am trying to get focused, when I activate RescueTime’s FocusTime I have IFTTT fire a Webhook to my Pushcut server to activate Do Not Disturb. Each part appears to operate successfully, solo but not together.

Here’s my IFTTT error:

Same response with GET & POST :man_shrugging:t3:

Thoughts, tips, suggestions most welcome…I have a reverse action too, fails with the same error, FWIW.

Happy Monday everyone.

Have you tried getting the example on the PushCut site to work?

Once you have that working, you can change (/recreate) the trigger and the shortcut. That should give you a logical progression to follow to narrow down at what point the issue really occurs, or with any luck, it will work.

1 Like

I can get a notification to work, just cannot get Pushcut to run a shortcut.The example works well, but only produces a notification and not a shortcut. :frowning: On to the next attempts.


Okay next checks.

  1. Your PushcCut Automation Server is running.
  2. Your IFTTT webhook URL to run your shortcut is of the form
  3. If your shortcut name has any non alphanumeric characters (e.g. spaces), you have URL-ENCODED them (e.g. space is %20).


Thanks for the follow up!

  1. Yes, confirmed on my other devices of the status.
  2. Yep, I copy it directly from Pushcut.

Same result using the Pushcut integration directly with IFTTT :frowning:

Lots of opportunities for Pushcut, excited to use it more.

Okay, from that I can see that IFTTT is firing and it’s going all the way through to PushCut on your device, which is receiving it. Then when it tries to run the shortcut, something is failing, but we don’t know what. So the issue looks to be local.

I did a few quick tests of my own using an IFTTT web hook and PushCut request. The results are listed below.

I was able to successfully trigger a shortcut that played a beeping sound. That was my control test.

I then tried to trigger a shortcut using the exact same IFTT applet, but amended for a shortcut that does not exist on my device (I added an “X” to the end of the shortcut name). The result this time was a failure, but the last line of the message was very different to the message you got. It was a could not find rather than a failed to run.

I also checked the result from a second device through the monitoring feature as it appears you have done above. I’m happy to say that the presentation of the error message was identical, so that covers off your error message simply being a mismatch.

The final test was to run a shortcut that sets do not disturb as you describe. As such it is a very simple shortcut and I assume yours would be identical (right?)

The result was that the shortcut run successfully and my device was put into DND mode.

Overall, I think this proves the premise that what you have described should work.

Can you try the following:

  1. Restart the iPhone 6 that is running your automation server and retest.
    • This should eliminate the chance of any general glitchiness of the device being in play.
  2. Try using your iPad as the automation server instead and see if the shortcut can be executed from that device.
    • It may be something about the particular device (hardware, software, a combination). Using the iPad for a test will help determine if it is something specific to the device running your automation server.
  3. Share your shortcut so others can test it on their set-up.
    • This will make it easier for others to independently validate your results. If it is a shortcut issue, this should flag it up pretty quickly.

Hopefully one of these three actions will get us another step closer to tracking down where the issue lies.

1 Like

Hi again.

Great troubleshooting steps, thanks.

  1. No difference.

  2. Success on the iPad.

  3. Not yet, as the issue appears to be resolved.

  4. Can I have Pushcut run the shortcut on other devices running, and registered with, Pushcut? Can I turn on DND on all myiOS devices, using Pushcut?
    4.1 Is there a way I can add a step to the automation to also turn DND on my Mac(s)?

Thanks in advance.
This will be quite the productivity hack if I (we) can pull it off.


PS It now runs from Zapier too now, the iPhone 6 was the issue, which is where I was running the server. Running on a current iPad Air is solid every time.

I don’t think so without them all running the server and receiving separate triggers, and we already know that isn’t working for your iPhone 6. Depending upon if it is fundamentally a trigger or execution issue, sending yourself a mail or message as another step could be used to trigger DND on the other devices.

You could add a step in Shortcuts or Zapier to write a file that is synced to your Macs that some local monitor (e.g. Hazel, Keyboard Maestro, folder action) could use to trigger a script to enable DND.

You could add SSH actions to your Shortcut to trigger a DND script directly on each Mac.

If you have a service that can receive a web request (e.g. Keyboard Maestro), you could also trigger with a URL call.

Thanks @sylumer DND on the Mac is now done via Keyboard Maestro’s Remote Trigger (Keyboard Shortcut) & Zapier. I will post the entire solution, inc. all the pieces when it’s 100% done, I think others might like to use it.

The pieces of the puzzle are falling together. Going to start a new topic for the multiple device challenge.