Add device mockup on Shortcuts input using Picsew?

Since I often manually put a device mockup around a recent screenshot (including cleaning up the status bar) using Picsew, I would like to automate that. Unfortunately Picsew does not support Shortcuts directly, but it does support X-Callback-URL schemes.

This URL seems to partially do what I want:


When I activate it:

  • runs on the last screenshot
  • puts a black device mockup around that last screenshot
  • cleans up the status bar
  • copies the result to the clipboard
  • deletes the original image without mockup.

However, what I really want is that it:

  • lets me select a screenshot in Photos (activate the shortcut on a selected screenshot using the Sharing menu)
  • puts a black device mockup around that selected screenshot
  • cleans up the status bar
  • copies the result to the clipboard
  • deletes the original (selected) image without mockup.

I probably need a URL like this:


In this case the shortcut should take care of copying the input to the clipboard and deleting the selected screenshot. However, I already fail at copying the input (selected screenshot) to the clipboard…

How can I do this?

This looks to work.

Yes, but it seems to do the same as I was already able to do:

It “only” works on the last screenshot, but not on a (manually) selected one?

The latter is what I want: select a screenshot in Photos, open this shortcut from the Share menu and let it work with the selected screenshot.

I’ve modified it a little to that this one would allow you to select it in Shortcuts, foregoing Photos, or pass it in from Photos via the share sheet.

In my testing, both result in a framed version of the original image being present on the clipboard.

1 Like

Ha, you’re even 1 step ahead of me: checking whether there is input or not would have been my next step…

Unfortunately there seems to be something wrong with my iPhone setup. Your shortcut worked exactly once when activating via the Share menu after selecting a screenshot. After that it no longer worked for that code path… (No clue what’s wrong with my setup)

Maybe try a reboot?

Working fine for me on latest public release on iPhone 8+.

Any chance someone could update this with new mockup2 parameters. Struggling to get my black iPhone 14 pro mockup to work.

The change is to replace the mockup parameter and value with the mockup2 parameter and value. I’ve posted the modification below, but what was the underlying problem you were having in getting this to work?

Thank you! I’m not entirely sure. I think when I copied phone model and pasted it in. I might of deleted to much on the callback url.